CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Paraview & paraFoam (http://www.cfd-online.com/Forums/openfoam-paraview/)
-   -   Error while postprocessing channelOodles tutorial in OpenFOAM 13 (http://www.cfd-online.com/Forums/openfoam-paraview/61285-error-while-postprocessing-channeloodles-tutorial-openfoam-13-a.html)

alberto April 6, 2006 15:34

While post-processing the chan
 
While post-processing the channelOodles tutorial case in OpenFOAM 1.3, when I select a time step in ParaView and click on Accept, I get the following error message:

alberto@dimension4400:~/OpenFOAM/alberto-1.3/run/tutorials/channelOodles> paraFoam . channel395
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.3 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/



--> FOAM FATAL ERROR : Not implemented

From function void CyclicPointPatchField<patchfield,>::evaluate()
in file /home/dm2/henry/OpenFOAM/OpenFOAM-1.3/src/OpenFOAM/lnInclude/CyclicPointPatchFie ld.C at line 187.

FOAM aborting

/home/alberto/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4/paraview-real: symbol lookup error: /home/alberto/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libOpenFOAM.so: undefined symbol: cplus_demangle

The case can be postprocessed without problems using OpenFoam 1.2.

How can I solve the problem?

Thanks in advance,
Alberto

mattijs April 8, 2006 08:26

can you report this as a bug?
 
can you report this as a bug?

Two workarounds (not tested):
- use foamToVTK with -noPointValues
- change the cyclic patchFields temporarily to be e.g. fixedValue (and change the cyclicPolyPatch type in the polyMesh/boundary file accordingly)

alberto April 8, 2006 12:59

Sure, I'll add it to the bug d
 
Sure, I'll add it to the bug discussion forum.

Thanks. I'll try your suggestions immediatly.

Unfortunately I've just tried to install OpenFOAM 1.3 on our Rocks cluster and it's not running due to incompatibilities in libs.so.6 versions.

I tried to create a compatibility environment as explained by Novell in http://www.novell.com/coolsolutions/feature/11775.html but it doesn't work http://www.cfd-online.com/OpenFOAM_D...lipart/sad.gif.
I hope to find a solution soon.

Best regards,
Alberto

anne April 12, 2006 13:25

Indeed, I also have the same b
 
Indeed, I also have the same bug when using
paraFOAM on the channelOoles case and dowloading
the field at a time step.

Any solution instead of having to change all the
cyclic ?

Thanks

mattijs April 13, 2006 05:58

See http://www.cfd-online.c
 
See

http://www.cfd-online.com/cgi-bin/Op...=7286#POST7286


All times are GMT -4. The time now is 19:36.