CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Paraview & paraFoam (http://www.cfd-online.com/Forums/openfoam-paraview/)
-   -   ParaFoam instalation in OpenFoam 1.5 dev (http://www.cfd-online.com/Forums/openfoam-paraview/78480-parafoam-instalation-openfoam-1-5-dev.html)

titio July 22, 2010 15:42

ParaFoam instalation in OpenFoam 1.5 dev
 
Hi foamers,

Is it possible to install and use paraview/parafoam in OpenFoam 15.dev. I am trying to correct the script that comes with OpenFoam 1.5 dev, using as a base the script of OpenFoam 1.6, but it is costing me a lot.

Can anyone help out, or, is it easier to install openFoam 1.7 in the same account and change the environmemt variables in .bashrc whenever desirable.

Regards,

Titio

wyldckat July 23, 2010 06:34

Greetings Titio,

I have pretty much no experience with the -dev project, but as far as I can tell, it should be as simple as in the official OpenFOAM. You have to edit the file "OpenFOAM-1.5-dev/etc/apps/paraview3/bashrc" and tweak it to suit your needs and make it point to your installed ParaView!

Or you can leave that file intact and try to use the official ParaView version 3.8.0, which now comes with its own working foam reader, thankfully to Takuya's plugin :). I've posted on my blog on this forum on how to do this: Using the official pre-built ParaView 3.8.0 version with OpenFOAM...
Hopefully it will work with the -dev project as well!

Best regards,
Bruno

ericnutsch July 24, 2010 23:24

Sourcing 1.5 dev seems to disrupt the operational of paraview.

I source openfoam in a shell each time I run it (no in my user .bashrc file) and run foamToVTK. I then open up paraview from a different shell and locate the files manually, or use paraDisplay(my own little code snipit).

http://www.cfd-online.com/Forums/ope...-parafoam.html

Im in the process of getting paraDisplay to work with 1.5dev in the same shell. I will post it when I write it.


All times are GMT -4. The time now is 23:14.