CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

ParaFoam instalation in OpenFoam 1.5 dev

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 22, 2010, 16:42
Default ParaFoam instalation in OpenFoam 1.5 dev
  #1
Senior Member
 
Antonio Martins
Join Date: Mar 2009
Location: Porto, Porto, Portugal
Posts: 112
Rep Power: 7
titio is on a distinguished road
Send a message via MSN to titio Send a message via Skype™ to titio
Hi foamers,

Is it possible to install and use paraview/parafoam in OpenFoam 15.dev. I am trying to correct the script that comes with OpenFoam 1.5 dev, using as a base the script of OpenFoam 1.6, but it is costing me a lot.

Can anyone help out, or, is it easier to install openFoam 1.7 in the same account and change the environmemt variables in .bashrc whenever desirable.

Regards,

Titio
titio is offline   Reply With Quote

Old   July 23, 2010, 07:34
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,730
Blog Entries: 33
Rep Power: 76
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings Titio,

I have pretty much no experience with the -dev project, but as far as I can tell, it should be as simple as in the official OpenFOAM. You have to edit the file "OpenFOAM-1.5-dev/etc/apps/paraview3/bashrc" and tweak it to suit your needs and make it point to your installed ParaView!

Or you can leave that file intact and try to use the official ParaView version 3.8.0, which now comes with its own working foam reader, thankfully to Takuya's plugin . I've posted on my blog on this forum on how to do this: Using the official pre-built ParaView 3.8.0 version with OpenFOAM...
Hopefully it will work with the -dev project as well!

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   July 25, 2010, 00:24
Default
  #3
Senior Member
 
Eric Nutsch
Join Date: Sep 2009
Location: Eugene, Oregon USA
Posts: 112
Rep Power: 7
ericnutsch is on a distinguished road
Send a message via Skype™ to ericnutsch
Sourcing 1.5 dev seems to disrupt the operational of paraview.

I source openfoam in a shell each time I run it (no in my user .bashrc file) and run foamToVTK. I then open up paraview from a different shell and locate the files manually, or use paraDisplay(my own little code snipit).

Alternative to paraFoam

Im in the process of getting paraDisplay to work with 1.5dev in the same shell. I will post it when I write it.
ericnutsch is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 1.5 dev LVDH OpenFOAM 98 May 5, 2010 18:01
ParaView/ParaFoam in OpenFoam 1.5 dev titio OpenFOAM Paraview & paraFoam 2 February 27, 2010 15:02
Paraview/Parafoam in OpenFoam 1.5 dev titio OpenFOAM Post-Processing 0 December 9, 2009 13:13
Paraview/Parafoam in OpenFoam 1.5 dev titio OpenFOAM Paraview & paraFoam 0 December 9, 2009 13:12
Problem running paraFoam on OpenFOAM 1.5 sonny OpenFOAM 3 June 6, 2009 21:24


All times are GMT -4. The time now is 10:47.