CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Paraview & paraFoam

error when compiling ParaView 3.8.0 on ubuntu10.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 12, 2010, 07:36
Default [solved]error when compiling ParaView 3.8.0 on ubuntu10.04
  #1
New Member
 
Join Date: Apr 2010
Posts: 4
Rep Power: 7
lainme is on a distinguished road
I tried to compile paraview 3.8 on ubuntu10.04, but got the following error

Code:
make[2]: *** [Documentation/paraview.qch] error 127
make[1]: *** [Documentation/CMakeFiles/ParaViewOnlineHelp.dir/all] error 2
make: *** [all] error 2
It is exactly same with the problem described in this post

Installation problem with ParaView 3.8.0 on openSUSE 11.2

In the post, libqt4-devel-doc and libQtWebKit-devel is suggested to install.

But I can't find such packages in ubuntu10.04. By the way, I am using a 64bit version.

Last edited by lainme; August 12, 2010 at 22:15.
lainme is offline   Reply With Quote

Old   August 12, 2010, 11:50
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,488
Blog Entries: 34
Rep Power: 86
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings lainme and welcome to the forum!

The packages you are missing in Ubuntu 10.04 are likely these:
Code:
libqt4-dev qt4-dev-tools
Additionally you might need these too:
Code:
libpng12-dev libxt-dev libxi-dev libxrender-dev libxrandr-dev libxcursor-dev libxinerama-dev libfreetype6-dev libfontconfig1-dev libglib2.0-dev freeglut3-dev
Source: http://www.cfd-online.com/Forums/ope...tml#post268828 - post #4
For building documentation, see also post #9.

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   August 12, 2010, 21:28
Default
  #3
New Member
 
Join Date: Apr 2010
Posts: 4
Rep Power: 7
lainme is on a distinguished road
thanks for your reply. I have checked that post and installed all the packages mentioned. But it doesn't work.

I also searched the paraview mailing list, and someone said the compiling will always fall on a 64bit system.
lainme is offline   Reply With Quote

Old   August 12, 2010, 21:34
Default
  #4
New Member
 
Join Date: Apr 2010
Posts: 4
Rep Power: 7
lainme is on a distinguished road
solved the problem. I compiled it under a directory containing Chinese characters, that's where the error came from.

Last edited by lainme; August 12, 2010 at 22:14.
lainme is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Qt version of Paraview 3.8.0 in OpenFOAM 1.7 waynezw0618 OpenFOAM Installation 10 March 3, 2011 09:53
paraview installation woes vex OpenFOAM Installation 15 January 30, 2011 08:11
Installation problem with ParaView 3.8.0 on openSUSE 11.2 aero_ OpenFOAM Paraview & paraFoam 14 August 2, 2010 18:13
Problems in compiling paraview in Suse 10.3 platform chiven OpenFOAM Installation 3 December 1, 2009 08:21
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41


All times are GMT -4. The time now is 20:33.