CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Paraview & paraFoam (
-   -   connection to external server (

gandesk November 24, 2010 12:09

connection to external server
Hello all,

I run my simulation using openfoam at a supercomputer server. Now that I want to connect to that server through my paraview installed on my pc. Is that possible to do with the file>connect option in paraview?? If I can do that, I would be able to save lot of time...

Please help me how to connect to that remote server??

s_braendli January 11, 2011 11:28

I followed the instructions given here:

On the server-side I only used step 3. On my desktop-computer I just started ParaFOAM and added the server as described. Unfortunately I was only able to display VTK-files, not the whole OpenFOAM-case, as I usually do with PF. I would be happy for any hint about this.

best regards

sahm January 12, 2011 23:04

not working
I did that, then the server says:
Listen on port: 11111
but when I try to connect trough the client, that's not working and I recieve this error:
p, li { white-space: pre-wrap; } Warning: In /home/kitware/ParaView-3-8/ParaView-3.8.1/src/Servers/Common/vtkProcessModuleConnectionManager.cxx, line 292
vtkProcessModuleConnectionManager (0x8d3bff8): Connect failed. Retrying for 1.79072 more seconds
what do you think that is for? what should I do? Is that because of firewall settings or something else?

wyldckat January 13, 2011 19:18

Greetings to all!

@sahm: when you are trying to connect to a computer inside another network, you better use ssh tunneling. For example, run something like this:

ssh my_user_name@target_host -L 11150:the_name_or_IP_of_host_where_pvserver_is:11111 -g -C
This will open a tunnel between your machine and the pvserver machine, while passing through the target_host where you use ssh to connect to.
Then open ParaView locally to target the "address: port" "localhost:11150". And voilį, you have a ssh tunnel through firewalls, as long as the firewalls allow ssh tunneling, which they usually do. This is how sometimes people can connect to the world wide web at work, on a restricted internet access network.

@Silvan: while inside your remote case folder, run either one of these commands:

touch case.foam
paraFoam -touch

The result of the first one will only open with ParaView 3.8.0 or above; the result of the second one will only work if the PV3FoamReader plugin that comes with OpenFOAM is properly compiled for the ParaView build being used.

Best regards,

s_braendli January 14, 2011 06:25

Nice, I didn't know I had to open the case.foam with PF. No it works fine.

Thanks a lot

sahm January 14, 2011 11:58

ssh my_user_name@target_host -L 11150:the_name_or_IP_of_host_where_pvserver_is:11111 -g -C

Excuse me, I don't understand which one is target_host? is that the client or the server,
and should I enter this command inside paraview, where I'm defining the server address ( like in those links) or in the linux terminal? ( don't know much about linux)
Sorry but I need more like step by step one.
what is 11150? is that connection port on pvserver or my computer.
Imagine I`m working on
and my pvserver is located on ( don't try at home ), which I can get connected to using ssh and run in terminal : pvserver. and my user name is same for both.
can you tell me the command above using these two names?

wyldckat January 14, 2011 17:15

Hi Sahm,

OK then, let me try to explain it this way:
  1. In a Linux terminal/console on your local machine "", run:

    ssh -L 11150:localhost:11111 -g -C
    I assumed your user name was "sahm". The "-g" activates some sort of reflection of ports and "-C" activates compression for the connection. Run "man ssh" to learn more.
  2. Launch pvserver at "" (your connected to it from the previous command), as explained on this section: Setting up a ParaView Server#Running the Server
    If you just want to test how it works, simply run:

  3. Now, launch ParaView in your machine "" (on another terminal/console window):

  4. Now, in the ParaView menu, choose "File->Connect".
  5. A dialog pops up. Click on "Add server".
  6. Fill in the boxes:
    • Give it a name, e.g. "remote machine";
    • Choose "Server Type" as "Client / Server";
    • Host: localhost
    • Port: 11150
  7. Press "Configure".
  8. Another dialog Pops up. Set in "Startup Type" to "Manual".
  9. Press "Save".
  10. You now go back automatically to the dialog from point 5. Select the added server and press "Connect".
  11. And voilą, you're connected to your remote server!
If this still doesn't work, read this very complete section of the first link and also browse through the links it has: Connecting Through a Firewall
This can also be good to know: Starting the server

By the way, what I wrote in my previous post was a more generic tunneling, where for example, you could only connect to "" through "". In this case, you would run like this:

ssh -L -g -C
Best regards and good luck!

sahm January 14, 2011 22:19

Thanks for reply, I`ll try that. one more question, what is voilį?

wyldckat January 15, 2011 08:49

Hi Sahm,


Originally Posted by sahm (Post 290515)
one more question, what is voilį?

Actually, I wrote it wrong, it's "voilą" :rolleyes: I gotta remember the accent properly, if I'm to continue using this expression :)

I'll quote it's meaning from another site:

Originally Posted by
It's a French word that translates to "here" in English. It's usually used as a slang term to say "ta da" sort of expression if you know what I mean by that. Also usually pronounced wrong by Americans for some reason, they like to say it like "wala."

"Voila" is used to call attention to or express satisfaction over something. EX: "Then you add onions and tomatoes to it, voila!, you have a delicious pizza."

And quoting from an online dictionary:

Originally Posted by
Used to call attention to or express satisfaction with a thing shown or accomplished: Mix the ingredients, chill, andą! light, tasty dessert.


Best regards,

sahm January 19, 2011 11:55

voilą ;-)
Just to make it 10 Charracters.

All times are GMT -4. The time now is 22:18.