CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Post-Processing (http://www.cfd-online.com/Forums/openfoam-post-processing/)
-   -   problem in para veiw (http://www.cfd-online.com/Forums/openfoam-post-processing/116689-problem-para-veiw.html)

mdrehan April 23, 2013 07:44

problem in para veiw
 
hello Foamers
after running the openfoam the inthe para view wen i click apply tab it gives following error


borted (core dumped)
user@ubuntu:~/OpenFOAM/user-2.2.0/run/waterChannel$ paraFoam
created temporary 'waterChannel.OpenFOAM'
fileName::stripInvalid() called for invalid fileName alpha1~
For debug level (= 2) > 1 this is considered fatal
Aborted (core dumped)
user@ubuntu:~/OpenFOAM/user-2.2.0/run/waterChannel$ ^C
user@ubuntu:~/OpenFOAM/user-2.2.0/run/waterChannel$ paraFoam
created temporary 'waterChannel.OpenFOAM'

please help...:confused:

bscphil April 23, 2013 08:42

Quote:

Originally Posted by mdrehan (Post 422560)
hello Foamers
after running the openfoam the inthe para view wen i click apply tab it gives following error

fileName::stripInvalid() called for invalid fileName alpha1~
For debug level (= 2) > 1 this is considered fatal
Aborted (core dumped)

please help...:confused:

Hey, the error is due to the file "alpha1~", this is the backup-file of the original alpha1-file. Don't know why paraview is looking for that ?

But, do something like this:
  1. write "paraFoam" in the shell
  2. uncheck the volume fields in the object inspector
  3. check only one of your solution variables and may attempt of the given time directory, because maybe the alpha1-file wasn't wrote in the 0-dict (this is the default dict by press apply)
  4. before press apply select the latest time step in the upper toolbar
Hope i can help you, sorry for my poor english :rolleyes:

JR22 April 23, 2013 09:48

Another thing you can try is the command line foamToVTK, and then open the generated VTK files from paraview (not paraFoam). If this approach works, then your problem might be in the paraFoam installation, if this approach doesn't work, then your problem is likely in your mesh/solution.

mdrehan April 24, 2013 00:56

hey phillip,
thanks for the reply and it worked...

mdrehan April 24, 2013 01:13

hello Phillip,
can you please explain what is the reason for skipping the the zero timestep?

bscphil April 24, 2013 04:11

Quote:

Originally Posted by mdrehan (Post 422728)
hello Phillip,
can you please explain what is the reason for skipping the the zero timestep?

The reason for skipping is because there isn't a alpha1-file in the 0-dict! Or not?? Did you define the alpha1-file in your 0-dict?


All times are GMT -4. The time now is 10:09.