CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Post-Processing (http://www.cfd-online.com/Forums/openfoam-post-processing/)
-   -   an odd behavior on continuity error (http://www.cfd-online.com/Forums/openfoam-post-processing/120390-odd-behavior-continuity-error.html)

immortality July 5, 2013 15:37

an odd behavior on continuity error
 
1 Attachment(s)
continuity error is being displayed in some time after 0 time instead of begining the run as is shown.what may be wrong with continuity error?

wyldckat July 7, 2013 10:27

Why do you think it's odd? It seems perfectly fine to me.

The values are all very small and it's somewhat indicative that the flow is going back and forth, leading to the cumulative errors to go back and forth as well.

immortality July 20, 2013 12:56

Hi
it seems it doesn't solve continuity equation when residuals are a horizontal line.

wyldckat July 21, 2013 05:15

Hi Ehsan,

Mmm... without a test case, and from the looks of the graph, my guess is that the continuity errors are below the floating point resolution (http://en.wikipedia.org/wiki/Machine_epsilon) for the first several iterations.

I vaguely remember seeing very low values for one of the solvers where I added the continuity calculation, at your request. I found it odd, but I assumed it would always be so low and it was why it was not originally present in the solver.
In other words, either the continuity calculation was not necessary for the solver in question or something might be missing in the continuity equation.

Best regards,
Bruno


All times are GMT -4. The time now is 10:05.