CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Post-Processing (
-   -   Cl and Cd values very high (

Phizz82 August 9, 2013 15:42

Cl and Cd values very high
Hi there.

I have managed to run my aerofoil simulation but I am getting very high values of Cd and Cl. I anticipated that there may be a bit of a problem with no modelling as a compressible flow (I used the SimpleFoam solver) but not to this extent!

I have attached the my project folder if anyone can help.


immortality August 10, 2013 14:53

send necessary files to me so that see if can do something:

Phizz82 August 10, 2013 15:04

Thanks immortality. Which filed would you need? I would guess posy processing, controldic and the whole of the 0 folder?

immortality August 10, 2013 15:09

0 folder constant and system if you want me run it otherwise whatever you know may the problem be there.

immortality August 10, 2013 16:03

why you have set rhoInf 1000? is the environment water?
but you have:
transportModel Newtonian;

rho rho [ 1 -3 0 0 0 0 0 ] 0.42;

nu nu [ 0 2 -1 0 0 0 0 ] 1.47e-05;

Phizz82 August 10, 2013 16:06

The environment is air at approx 11km. I have been trying to build this up from tutorials without knowing everything behind it and must have missed that. Would my rhoInf be 0.42 too or is there an equation that determines another value for it?

immortality August 10, 2013 16:12

yes it would be .42
correct it a look at other files it and I have a look if another problem occurred.

Phizz82 August 10, 2013 16:16

>.< silly me.. of course all the values ...inf are freestream aren't they. No wonder my values were so high as only the area what a true representation. So it takes the forcecoeffs actually pulls out a lift,drag, moment values and then divides them by 1/2 rho v^2 s. I think I see where I was going wrong. Thank you very much.

Phizz82 August 10, 2013 16:17

Values are now in the 0.02 area for drag which seems a lot better!

immortality August 11, 2013 02:41

then it has been resolved?
I'm glad.what about Cl?
Send me your new settings.I want to have a look into it.

somFoam June 30, 2015 04:01

Very high Cl
P { margin-bottom: 0.08in; } Hi,
I was working on OpenFoam 2.3.1. Simulated some turbulence model with komega sst for flow past Circular Cylinder Re=100000, Cd=1.12, but always getting very high cl, rms =1.
Please suggest, if there is any trick.

immortality June 30, 2015 05:38

is your grid fine enough near the wall of the cylinder to include viscous layer?

somFoam June 30, 2015 06:02

Very high Cl
1 Attachment(s)
I am using wallfunction, finess is such that, yplus value varying from 18 to 310, with average 172.

somFoam June 30, 2015 06:06

High Cl value
:confused: please help, I have attached my case above.

All times are GMT -4. The time now is 22:34.