CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Post-Processing (http://www.cfd-online.com/Forums/openfoam-post-processing/)
-   -   Not able to store the velocity data In edited pimpleFoam (http://www.cfd-online.com/Forums/openfoam-post-processing/123561-not-able-store-velocity-data-edited-pimplefoam.html)

himanshu28 September 16, 2013 08:04

Not able to store the velocity data In edited pimpleFoam
 
Hi,

I have edited pimpleFoam to solve the Turbulent flow, heat transfer case and i have build my solver successfully and performed the validation also.

I am able to plot the velocity contours and able to see the velocity magnitude in the paraview.
But i am not able to see the Ux,Uy,Uz values in the log file generated after the solution even after using the FoamLog ,to plot the residuals.

So please somebody help me to come out of this problem.I have tested the case of TJunction of pimple Foam without heat equation and its printing the Ux ,Uy,Uz properly and even i use this T junction only to test the developed solver but is now printing the velocity components..
Regards
Himanshu:rolleyes:

himanshu28 September 16, 2013 09:59

Solution to the stated problem
 
Quote:

Originally Posted by himanshu28 (Post 452002)
Hi,

I have edited pimpleFoam to solve the Turbulent flow, heat transfer case and i have build my solver successfully and performed the validation also.

I am able to plot the velocity contours and able to see the velocity magnitude in the paraview.
But i am not able to see the Ux,Uy,Uz values in the log file generated after the solution even after using the FoamLog ,to plot the residuals.

So please somebody help me to come out of this problem.I have tested the case of TJunction of pimple Foam without heat equation and its printing the Ux ,Uy,Uz properly and even i use this T junction only to test the developed solver but is now printing the velocity components..
Regards
Himanshu:rolleyes:

Hi Foamers,

I got the solution for the problem this was happening because in my fvSolution file i wrote the following lines
Code:

momentumPredictor  no
and if you closely observe the UEqn for the pimpleFoam then U will find that the velocity correction based on the computed pressure value is assigned with the if condition.

hence I changed the
Code:

momentumPredictor  yes
and it started printing Ux, Uy,Uz with the the log file and now i can monitor the residuals easily.

One more thing if you don't add this line in ur fvSolution then it will be by default taken as yes.

Sorry for spamming but hope some body in future can use this advice if he get stuck.

Regards
Himanshu:)


All times are GMT -4. The time now is 06:34.