CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Post-Processing

Not able to store the velocity data In edited pimpleFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 16, 2013, 08:04
Question Not able to store the velocity data In edited pimpleFoam
  #1
Member
 
Himanshu Sharma
Join Date: Jul 2012
Posts: 81
Rep Power: 5
himanshu28 is on a distinguished road
Hi,

I have edited pimpleFoam to solve the Turbulent flow, heat transfer case and i have build my solver successfully and performed the validation also.

I am able to plot the velocity contours and able to see the velocity magnitude in the paraview.
But i am not able to see the Ux,Uy,Uz values in the log file generated after the solution even after using the FoamLog ,to plot the residuals.

So please somebody help me to come out of this problem.I have tested the case of TJunction of pimple Foam without heat equation and its printing the Ux ,Uy,Uz properly and even i use this T junction only to test the developed solver but is now printing the velocity components..
Regards
Himanshu

Last edited by himanshu28; September 16, 2013 at 09:52.
himanshu28 is offline   Reply With Quote

Old   September 16, 2013, 09:59
Talking Solution to the stated problem
  #2
Member
 
Himanshu Sharma
Join Date: Jul 2012
Posts: 81
Rep Power: 5
himanshu28 is on a distinguished road
Quote:
Originally Posted by himanshu28 View Post
Hi,

I have edited pimpleFoam to solve the Turbulent flow, heat transfer case and i have build my solver successfully and performed the validation also.

I am able to plot the velocity contours and able to see the velocity magnitude in the paraview.
But i am not able to see the Ux,Uy,Uz values in the log file generated after the solution even after using the FoamLog ,to plot the residuals.

So please somebody help me to come out of this problem.I have tested the case of TJunction of pimple Foam without heat equation and its printing the Ux ,Uy,Uz properly and even i use this T junction only to test the developed solver but is now printing the velocity components..
Regards
Himanshu
Hi Foamers,

I got the solution for the problem this was happening because in my fvSolution file i wrote the following lines
Code:
momentumPredictor  no
and if you closely observe the UEqn for the pimpleFoam then U will find that the velocity correction based on the computed pressure value is assigned with the if condition.

hence I changed the
Code:
momentumPredictor  yes
and it started printing Ux, Uy,Uz with the the log file and now i can monitor the residuals easily.

One more thing if you don't add this line in ur fvSolution then it will be by default taken as yes.

Sorry for spamming but hope some body in future can use this advice if he get stuck.

Regards
Himanshu
himanshu28 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
studying a valve case mina.basta OpenFOAM 33 August 30, 2013 04:46
unable to get parabolic velocity profile with pimplefoam houkensjtu OpenFOAM 4 October 8, 2012 04:41
[Help Please], Trouble Using UDF to Import Velocity Data -- But All Zeros :( rockymountai FLUENT 1 November 11, 2009 17:30
transient velocity profile with experimental data Janneke FLUENT 3 August 19, 2008 10:11
Terrible Mistake In Fluid Dynamics History Abhi Main CFD Forum 12 July 8, 2002 09:11


All times are GMT -4. The time now is 19:12.