CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Post-Processing (http://www.cfd-online.com/Forums/openfoam-post-processing/)
-   -   Function Object cloudInfo (http://www.cfd-online.com/Forums/openfoam-post-processing/130940-function-object-cloudinfo.html)

Mentalo March 6, 2014 07:42

Function Object cloudInfo
 
Hello,

if have seen that since OF v2.2.0 a functionality called cloudInfo was implemented. Im very interested in using this tool , but i have no idea of how this is done. Do i have to write a custom pre-processor to use this utility? Help would be appreciated. Thanks in advance.

http://www.openfoam.org/version2.2.0...processing.php

Regards
Mentalo

Mentalo March 7, 2014 04:06

Ok now I got it running. But there ist still a strange problem. On a singel core, without decomposing the case, the cloudInfo object works perfectly fine. But by starting the run on MPI, I get an error message:

Code:

faceSource cuttingplane_average output:
    areaAverage(sampledSurface) for p = 99991.3
    areaAverage(sampledSurface) for U = (7.71105e-05 -6.53393e-06 20.1689)
    areaAverage(sampledSurface) for T = 280.929
    areaAverage(sampledSurface) for rho = 1.23573
    areaAverage(sampledSurface) for C7H16 = 5.37203e-98

[philipp-Home:3137] *** An error occurred in MPI_Recv
[philipp-Home:3137] *** on communicator MPI_COMM_WORLD
[philipp-Home:3137] *** MPI_ERR_TRUNCATE: message truncated
[philipp-Home:3137] *** MPI_ERRORS_ARE_FATAL: your MPI job will now abort
--------------------------------------------------------------------------
mpirun has exited due to process rank 0 with PID 3137 on
node philipp-Home exiting improperly. There are two reasons this could occur:

1. this process did not call "init" before exiting, but others in
the job did. This can cause a job to hang indefinitely while it waits
for all processes to call "init". By rule, if one process calls "init",
then ALL processes must call "init" prior to termination.

2. this process called "init", but exited without calling "finalize".
By rule, all processes that call "init" MUST call "finalize" prior to
exiting or it will be considered an "abnormal termination"

This may have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).

The faceSource object works perfectly fine, either runing single or multi core.

I tried to execute the post processing, after reconstructing the case, via execFlowFunctionObjects, but then OpenFoam gets stuck saying:

Code:

Time = 0
    Reading phi
--> FOAM Warning :
--> FOAM FATAL IO ERROR:
cannot find file

file: /home/philipp/cfd/OF_22x/full_spray_SP1_5/0/phi at line 0.

    From function regIOobject::readStream()
    in file db/regIOobject/regIOobjectRead.C at line 73.

Time = 0.0005
    Reading phi
    Reading U
    Reading p
No finite volume options present

Selecting thermodynamics package
{
    type            hePsiThermo;
    mixture        reactingMixture;
    transport      sutherland;
    thermo          janaf;
    energy          sensibleEnthalpy;
    equationOfState perfectGas;
    specie          specie;
}

Selecting chemistryReader chemkinReader
Reading CHEMKIN thermo data in new file format

and it won't continue


All times are GMT -4. The time now is 15:51.