CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Post-Processing

reconstructPar with new TurbulentInletVelocity BC

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 7, 2014, 09:40
Default reconstructPar with new TurbulentInletVelocity BC
  #1
New Member
 
Simon
Join Date: Jan 2014
Posts: 3
Rep Power: 2
Nomis is on a distinguished road
Dear foamers,

I implemented a new BC based on turbulentInlet.
Now I try to run this case parallel.

While reconstruct I get the following error message:



Reconstructing fields for mesh region0

Time = 1e-05

Reconstructing FV fields

Reconstructing volScalarFields

ddt0(p)
rho
alphaSgs
ddt0(thermosi,p)
kSGS
rho_0
p
ddt0(rho,K)
ddt0(rho)
T
ddt0(rho,h)
muSgs

Reconstructing volVectorFields

U


--> FOAM FATAL IO ERROR:
compound has already been transfered from token
on line 382697 the empty compound of type List<vector>

file: /home/itsnas/uxcih/3_OpenFOAM/uxcih-2.2.2/run/beta0_RefCase_L_5_Di_swirlRankineTurbulentVelocity Inlet_TEST_local/processor0/1e-05/U.boundaryField.SWIRLERINLET_11.value at line 382697.

From function token::transferCompoundToken(const Istream& is)
in file lnInclude/token.C at line 103.

FOAM aborting

#0 Foam::error:rintStack(Foam::Ostream&) at ??:?
#1 Foam::IOerror::abort() at ??:?
#2 Foam::token::transferCompoundToken(Foam::Istream const&) at ??:?
#3 Foam::Istream& Foam:perator>><Foam::Vector<double> >(Foam::Istream&, Foam::List<Foam::Vector<double> >&) at ??:?
#4 Foam::Field<Foam::Vector<double> >::Field(Foam::word const&, Foam::dictionary const&, int) at ??:?
#5 Foam::swirlRankineFlowRateTurbulentInletVelocityFv PatchVectorField::swirlRankineFlowRateTurbulentInl etVelocityFvPatchVectorField(Foam::fvPatch const&, Foam:imensionedField<Foam::Vector<double>, Foam::volMesh> const&, Foam::dictionary const&) at ~/8_Software_Openfoam/Einlass_RBen/swirlRankineFlowRateTurbulentInletVelocity/swirlRankineFlowRateTurbulentInletVelocityFvPatchV ectorField.C:107
#6 Foam::fvPatchField<Foam::Vector<double> >::adddictionaryConstructorToTable<Foam::swirlRank ineFlowRateTurbulentInletVelocityFvPatchVectorFiel d>::New(Foam::fvPatch const&, Foam:imensionedField<Foam::Vector<double>, Foam::volMesh> const&, Foam::dictionary const&) at /usr/local/share/OpenFOAM/OpenFOAM-2.2.2/src/finiteVolume/lnInclude/fvPatchField.H:142
#7 Foam::fvPatchField<Foam::Vector<double> >::New(Foam::fvPatch const&, Foam:imensionedField<Foam::Vector<double>, Foam::volMesh> const&, Foam::dictionary const&) at ??:?
#8 Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh>::GeometricBoundaryField::readField( Foam:imensionedField<Foam::Vector<double>, Foam::volMesh> const&, Foam::dictionary const&) at ??:?
#9 Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh>::readFields(Foam::dictionary const&) at ??:?
#10 Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh>::readFields() at ??:?
#11 Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh>::GeometricField(Foam::IOobject const&, Foam::fvMesh const&) at ??:?
#12
at ??:?
#13
at ??:?
#14
at ??:?
#15 __libc_start_main in "/lib64/libc.so.6"
#16
at /usr/src/packages/BUILD/glibc-2.11.3/csu/../sysdeps/x86_64/elf/start.S:116
Abbruch
Exitcode 134


decompose and the solver itsself run without any error message.
The solver writes perfect U files for every processor.
I also tried different decompose methods (scotch, simple) but still get the same error message.
Running the case with one processor over little time shows no problems.

The new bc is used on patch SWIRLERINLET_11.
So this might be the problem ;-)
There have been no errors while compiling the new bc.

Does anybody know what is wrong with the function token::transferCompoundToken(const Istream& is) in token.C?
Thanks a lot in advance!

Simon
Nomis is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
reconstructPar --> fileName::stripInvalid() called for invalid fileName commandtouse adona058 OpenFOAM Bugs 16 June 8, 2014 05:24
reconstructPar does not work in interDyMFoam ageorg OpenFOAM Post-Processing 3 November 8, 2013 01:29
reconstructPar and a high number of snapshots fs82 OpenFOAM Programming & Development 2 April 18, 2012 04:37
Problem with reconstructPar, please HELP quartzian OpenFOAM 1 September 24, 2009 06:11
Problem with reconstructPar fabianpk OpenFOAM 5 August 14, 2007 09:17


All times are GMT -4. The time now is 12:09.