CFD Online URL
[Sponsors]
Home > Forums > OpenFOAM Post-Processing

Problem with sample utility

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 23, 2007, 12:53
Default hi me again. i read about the
  #1
Member
 
robert maduta
Join Date: Mar 2009
Posts: 33
Rep Power: 7
roberthino is on a distinguished road
hi me again. i read about the sample utility and decided that it is a much cleaner way to plot graphs than probe. my problem is that after i finished a calculation with FoamX and i puch the execute button for sample (configuration: uniform, along a line) it is initializing the mesh and writing something for every iterationstep, but than if i take a look in the dictionary on my hd (sample) and if i go to any iterationstep, there is absolutely no data written there? someone can help?
roberthino is offline   Reply With Quote

Old   August 23, 2007, 14:16
Default All data extracted using the s
  #2
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 697
Rep Power: 10
msrinath80 is on a distinguished road
All data extracted using the sample utility gets written to a new directory called samples inside your case.
msrinath80 is offline   Reply With Quote

Old   August 23, 2007, 14:21
Default jup thats what i thought....in
  #3
Member
 
robert maduta
Join Date: Mar 2009
Posts: 33
Rep Power: 7
roberthino is on a distinguished road
jup thats what i thought....in that samples directory there are all the iterations steps in new directories. but these directories are empty there is no data
roberthino is offline   Reply With Quote

Old   August 23, 2007, 14:25
Default That's odd. Do one thing. Use
  #4
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 697
Rep Power: 10
msrinath80 is on a distinguished road
That's odd. Do one thing. Use the default caviy case with icoFoam and extract the velocities along a line through the center of the cavity. See if that works first.
msrinath80 is offline   Reply With Quote

Old   August 23, 2007, 15:39
Default Hallo Robert, 1. Which vers
  #5
Senior Member
 
Jens Klostermann
Join Date: Mar 2009
Posts: 117
Rep Power: 7
jens_klostermann is on a distinguished road
Hallo Robert,

1. Which version of OF do you use? I had also some problems with sampling in OF-1.3? Try to change the interpolation in the sampleDict.

2. Make sure your sample line (coordinates of first and last point) is within your domain!

Jens
jens_klostermann is offline   Reply With Quote

Old   August 23, 2007, 16:14
Default thx a lot, i use version 1.4..
  #6
Member
 
robert maduta
Join Date: Mar 2009
Posts: 33
Rep Power: 7
roberthino is on a distinguished road
thx a lot, i use version 1.4......well my first and last point are exactly on my left and right boundary. is that allowed? anyway i am going to try it tomorrow at the pc at work. what do you mean by changing the interpolation? i used uniform and 100 points in between
roberthino is offline   Reply With Quote

Old   August 23, 2007, 16:29
Default I faced the same problem a whi
  #7
Senior Member
 
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 697
Rep Power: 10
msrinath80 is on a distinguished road
I faced the same problem a while ago[1]. The suggestion was to move to the cloud option as opposed to the line option. Check the thread below for more information.

[1] http://www.cfd-online.com/OpenFOAM_D...es/1/3611.html
msrinath80 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sample utility problems msrinath80 OpenFOAM Running, Solving & CFD 12 December 21, 2012 06:51
OF15x sample utility does not accept component elisabet OpenFOAM Bugs 2 February 18, 2009 12:58
Sample utility problem in OpenFOAM141dev 7islands OpenFOAM Bugs 1 January 4, 2008 09:34
About the problem of decomposePar utility zou_mo OpenFOAM Running, Solving & CFD 3 July 27, 2005 19:18
SOLAVOF Sample Test Problem Zi-Wei Chiou Main CFD Forum 0 October 27, 2001 01:35


All times are GMT -4. The time now is 13:21.