CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Post-Processing

PostChannel

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 10, 2007, 05:35
Default postChannel works fine on tuto
  #1
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 9
maka is on a distinguished road
postChannel works fine on tutorial case. Also it works on a half-channel (2 blocks in y direction), full channel 4 blocks (ordered in y direction). I tried it on half-channel (1 block) and it gave me the following error:

Quote:

Create mesh for time = 0


Reading transportProperties
Collapsing fields for time constant
Collapsing fields for time 0
Collapsing fields for time 1000
Foam::error::printStack(Foam:stream&)
Foam::sigSegv::sigSegvHandler(int)
/lib64/tls/libc.so.6 [0x3072c2e2b0]
postChannel [0x437ed4]
postChannel [0x40e6a1]
__libc_start_main
__gxx_personality_v0
Segmentation fault

I checked the fields:
  • no nan.
  • paraFoam can visualize them.
.

Any idea what does that error message imply?

Best regards,
Maka.
maka is offline   Reply With Quote

Old   January 18, 2007, 06:44
Default error message reproduced on ch
  #2
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 9
maka is on a distinguished road
error message reproduced on channel395 tutorial

to reproduce the error message on channel395 tutorial:

(1) make a channel of one block. blockMeshDict
(2) remove boundary file.
(3) replace 0 folder with a copy of 0.org (no mapFields related issues).
(4) run and write 5 times step. controlDict
(5) run postChannel

related threads: 1

Thanks.
Best regards,
Maka.
maka is offline   Reply With Quote

Old   February 9, 2007, 12:43
Default Problem solved. That error
  #3
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 9
maka is on a distinguished road
Problem solved.

That error message was due to a mismatch between postChannelDict entries and the blockMeshDict.

postChannelDict requires entering the no cells in each block (blocks are only allowed normal to y direction), manually and it does not read it automatically from the mesh.

It is typical that you change the grid resolution or number of blocks in blockMeshDict and forget to update the postChannelDict accordingly which results in either bad collapsed profiles or the above error.

Best regards,
Maka.
maka is offline   Reply With Quote

Old   February 9, 2007, 12:49
Default related threads: 1
  #4
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 9
maka is on a distinguished road
related threads: 1
maka is offline   Reply With Quote

Old   July 16, 2009, 08:20
Default
  #5
Member
 
Marco Turchi
Join Date: Jul 2009
Location: Pesaro, Italy
Posts: 31
Rep Power: 7
zebu83 is on a distinguished road
Hi Maka,
i follow your instruction, but I receive this error:

Quote:
Create time

Create mesh for time = 0


Reading transportProperties
Collapsing fields for time 0
Collapsing fields for time 40
Collapsing fields for time 80
Collapsing fields for time 120
Collapsing fields for time 160
Collapsing fields for time 200
Collapsing fields for time 240
Collapsing fields for time 280
Collapsing fields for time 320
Collapsing fields for time 360
Collapsing fields for time 400
Collapsing fields for time 440
Collapsing fields for time 480
Collapsing fields for time 520
Collapsing fields for time 560
Collapsing fields for time 600
Collapsing fields for time 640
Collapsing fields for time 680
Collapsing fields for time 720
Collapsing fields for time 760
Collapsing fields for time 800
Collapsing fields for time 840
Collapsing fields for time 880
Collapsing fields for time 920
Collapsing fields for time 960
Collapsing fields for time 1000
end
and I can't view anythings new with paraview.

Any ideas?

Thank you

MT
zebu83 is offline   Reply With Quote

Old   July 22, 2009, 09:15
Default
  #6
Member
 
Marco Turchi
Join Date: Jul 2009
Location: Pesaro, Italy
Posts: 31
Rep Power: 7
zebu83 is on a distinguished road
I solve the problem... I download the OF patch (OpenFOAM-1.5.x) and after remake all, postChannel works fine.

The problem was in the postChannelDict, infact the new version is a little bit different.

Best regards

MT
zebu83 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
PostChannel utility not working in OpenFoam 15 nishant_hull OpenFOAM Running, Solving & CFD 15 January 18, 2012 06:26
PostChannel maka OpenFOAM Bugs 4 April 21, 2009 14:14
PostChannel Utility in openfoam15 not working nishant_hull OpenFOAM Bugs 0 August 14, 2008 15:49
Parallel postChannel from within channelOodles for DNS and LES maka OpenFOAM Running, Solving & CFD 1 February 18, 2008 14:08
PostChannel in parallel maka OpenFOAM Post-Processing 1 May 30, 2006 05:37


All times are GMT -4. The time now is 07:33.