CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Post-Processing

ReconstructPar channelOodles error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 25, 2005, 16:29
Default I'm running a parallel case on
  #1
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 9
maka is on a distinguished road
I'm running a parallel case on 2 processors with channelOodles (the standard case). I get this error when running reconstructPar on the case:

Create time

Create mesh

Time = 0

Reconstructing FV fields

Reconstructing volScalarFields

nuTilda
terminate called after throwing an instance of 'std::bad_cast'
what(): St8bad_cast
Aborted



Can any body help spot the problem. Thanks.

Maka
maka is offline   Reply With Quote

Old   November 25, 2005, 16:32
Default I think it is related to bound
  #2
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 9
maka is on a distinguished road
I think it is related to boundary condtions, since reconstructPar works fin on cavity. I would be grateful if any body can give suggestions.

/Maka
maka is offline   Reply With Quote

Old   November 28, 2005, 04:35
Default Does any body face the same pr
  #3
Senior Member
 
Maka Mohu
Join Date: Mar 2009
Posts: 305
Rep Power: 9
maka is on a distinguished road
Does any body face the same problem? Thanks.
maka is offline   Reply With Quote

Old   September 12, 2006, 09:14
Default I am having the same problem,
  #4
Senior Member
 
Daniele Panara
Join Date: Mar 2009
Posts: 101
Rep Power: 8
panara is on a distinguished road
I am having the same problem, could it be the cyclic BCs?

Daniele
panara is offline   Reply With Quote

Old   September 12, 2006, 17:41
Default Hello Daniele Are you using
  #5
Senior Member
 
santos's Avatar
 
Jose Luis Santos
Join Date: Mar 2009
Location: Portugal
Posts: 213
Rep Power: 9
santos is on a distinguished road
Send a message via Skype™ to santos
Hello Daniele

Are you using OpenFOAM 1.3? And in that case, are you using the last version of reconstructPar utility (check the bugs section of this forum)?

Regards
Josť Santos
santos is offline   Reply With Quote

Old   September 13, 2006, 02:00
Default Hi Jose', I am using OF 1.2
  #6
Senior Member
 
Daniele Panara
Join Date: Mar 2009
Posts: 101
Rep Power: 8
panara is on a distinguished road
Hi Jose',

I am using OF 1.2, and I am not sure of using the last version of reconstructPar...
Where I can get an updated version? I am searching in the bug section of this forum but I cannot find anything related to reconstructPar...
At which trend you are referring to?

Daniele
panara is offline   Reply With Quote

Old   September 13, 2006, 16:16
Default Hello I dont remember where
  #7
Senior Member
 
santos's Avatar
 
Jose Luis Santos
Join Date: Mar 2009
Location: Portugal
Posts: 213
Rep Power: 9
santos is on a distinguished road
Send a message via Skype™ to santos
Hello

I dont remember where I found it, but anyway try upgrading to OF 1.3, I think the problem is solved in the new version.

Regards
Josť Santos
santos is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in channelOodles tutorial alberto OpenFOAM Bugs 62 June 8, 2010 07:13
Bug in reconstructPar david OpenFOAM Bugs 10 May 26, 2009 12:11
Error with reconstructPar skabilan OpenFOAM Mesh Utilities 3 June 10, 2008 18:34
ReconstructPar error r2d2 OpenFOAM Pre-Processing 7 September 12, 2006 09:37
Error while postprocessing channelOodles tutorial in OpenFOAM 13 alberto OpenFOAM Paraview & paraFoam 4 April 13, 2006 05:58


All times are GMT -4. The time now is 13:52.