CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Post-Processing (
-   -   Results only visible when rotating (

janra March 22, 2009 13:43

Results only visible when rotating

I was following the cavity tutorial of OPenfoam and when I load the case in Paraview, I get to see the results only when I rotate the view. After I release my mouse button the view is still there for a second or so and then turns black. Is this normal?
How can I put it so that I get to see it all the time?



jeffkenning March 24, 2009 20:42

video drivers
The most common reasons I can think of is video drivers or composite desktop. (ie compiz or kde4). When I run paraFoam I have to turn off the kde4 composite (alt-shift-F12) or the display acts strange. You may try downgraded to a previous version to see if it will solve your problem.


phelbs March 25, 2009 03:06


Turning off compiz did the job for me (using Ubuntu 8.10 with ATI graphics card).


mahaputra April 24, 2009 19:58


Originally Posted by phelbs (Post 210724)

Turning off compiz did the job for me (using Ubuntu 8.10 with ATI graphics card).


Hei phelbs

i have exactly same problem like you

after i release the mouse, the view will not stable and change to black

i use ubuntu 8.10 OpenFOAM 1.5 on my office pc. but i forgot spec of the graphic card .

but its only happen for the visualisation on the paraview, others i.e linux ubuntu VLC media player will work fine.

let me check tomorrow morning.

please let me know, how you solve your problem.

phelbs April 25, 2009 02:48


Under System > Preferences > Appearance > Visual Effects:
Set effects to None

This step disables the fancy desktop effects but paraview should work now. If someone knows how to activate compiz effects with a working paraview, please let me know (ATI graphic card).


All times are GMT -4. The time now is 16:57.