CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Post-Processing

Pe tool error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 3, 2010, 05:03
Default Pe tool error
  #1
New Member
 
Join Date: Jul 2010
Posts: 17
Rep Power: 7
alf12 is on a distinguished road
Hi,

I would like to use the Pe tool, I use pisoFoam solver with kOmegaSST turbulence model.

When I run the Pe tool from my case directory, I get the following error message :
Code:
    Reading phi
    Calculating Pe
Selecting incompressible transport model Newtonian
Selecting RAS turbulence model kOmegaSST


--> FOAM FATAL ERROR: 

    lookup of RASProperties from objectRegistry region0 successful
    but it is not a RASModel, it is a dictionary
...
What is going wrong ?

Thanks
alf12 is offline   Reply With Quote

Old   September 9, 2010, 10:18
Default
  #2
New Member
 
Join Date: Jul 2010
Posts: 17
Rep Power: 7
alf12 is on a distinguished road
I still haven't found what is wrong. When I am trying to use 'Pe' tool with cavity tutorial (incompressible/pisoFoam/ras/cavity), I get the same error. Should that work ?
alf12 is offline   Reply With Quote

Old   October 22, 2010, 15:57
Default more info
  #3
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 543
Rep Power: 18
chegdan will become famous soon enough
What version of openfoam are you using?
chegdan is offline   Reply With Quote

Old   October 28, 2010, 05:13
Default
  #4
New Member
 
Join Date: Jul 2010
Posts: 17
Rep Power: 7
alf12 is on a distinguished road
I was using version 1.6 and now I have switched to 1.7.1 but the issue is still present.

I have skirted the issue by commenting line 103 in the Pe.C utility (actually I have done another tool based on the Pe tool to deal only with RAS). I hope I have not messed up calculations.

Code:
IOdictionary RASProperties(RASPropertiesHeader);
alf12 is offline   Reply With Quote

Old   November 2, 2010, 18:56
Default I think you are ok
  #5
Senior Member
 
chegdan's Avatar
 
Daniel P. Combest
Join Date: Mar 2009
Location: St. Louis, USA
Posts: 543
Rep Power: 18
chegdan will become famous soon enough
Quote:
Originally Posted by alf12 View Post
I was using version 1.6 and now I have switched to 1.7.1 but the issue is still present.

I have skirted the issue by commenting line 103 in the Pe.C utility (actually I have done another tool based on the Pe tool to deal only with RAS). I hope I have not messed up calculations.

Code:
IOdictionary RASProperties(RASPropertiesHeader);
It seems that there has been a change in teh structure of the RASProperties file since the Pe tool has been made. The RASProperties file looks different from 1.5-dev to 1.6.x and 1.7.x and without the turbulence model coefficients being defined in the RASProperties file in later versions. It seems to be that your change doesn't affect the calculation since the conculation actually uses a laminartransport model to determine the nueff in the Pe calculation...rather than one calculated from a turbulence model.

this is seen in the lines

Code:
                IOdictionary RASProperties(RASPropertiesHeader);

                singlePhaseTransportModel laminarTransport(U, phi);

                autoPtr<incompressible::RASModel> RASModel
                (
                    incompressible::RASModel::New
                    (
                        U,
                        phi,
                        laminarTransport
                    )
                );

                PePtr.set
                (
                    new surfaceScalarField
                    (
                        IOobject
                        (
                            "Pe",
                            runTime.timeName(),
                            mesh,
                            IOobject::NO_READ
                        ),
                        mag(phi)
                       /(
                            mesh.magSf()
                          * mesh.surfaceInterpolation::deltaCoeffs()
                          * fvc::interpolate(RASModel->nuEff())
                         )
                    )
                );
where the RASModel uses the laminarTransport transport property. This seems to be ok as long as there is a nu in the transport properties file to read into the Pe tool. hope that helps.

Dan
chegdan is offline   Reply With Quote

Old   August 20, 2011, 15:37
Default
  #6
Senior Member
 
maysmech's Avatar
 
Join Date: Jan 2010
Posts: 347
Blog Entries: 2
Rep Power: 8
maysmech is on a distinguished road
Hi,
Is it any solution found using Pe utility?
maysmech is offline   Reply With Quote

Old   August 25, 2011, 04:41
Default
  #7
New Member
 
Join Date: Jul 2010
Posts: 17
Rep Power: 7
alf12 is on a distinguished road
Quote:
Is it any solution found using Pe utility?
I'm still using version 1.7.1, so nothing has changed for me. Solution is to comment line 103 and to recompile Pe tool (likely as a separate tool)
alf12 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CGNS Compiling Diego Main CFD Forum 17 December 21, 2014 02:40
attach/detach (valve opening/closing) phsieh2005 OpenFOAM Running, Solving & CFD 2 March 21, 2009 06:18
OpenFOAM on MinGW crosscompiler hosted on Linux allenzhao OpenFOAM Installation 127 January 30, 2009 20:08
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
Compiling Netgen on Fedora Core is driving me crazy jango Open Source Meshers: Gmsh, Netgen, CGNS, ... 3 November 9, 2007 14:29


All times are GMT -4. The time now is 23:24.