CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Post-Processing (http://www.cfd-online.com/Forums/openfoam-post-processing/)
-   -   how to visualize lagrangian data (http://www.cfd-online.com/Forums/openfoam-post-processing/98672-how-visualize-lagrangian-data.html)

leefei March 15, 2012 22:44

how to visualize lagrangian data
 
hi all,

I'm using OpenFOAM 2.1.0.
And I have run the new tut cases hopperInitialState and hopperEmptying with the new solver icoUncoupledKinematicParcelFoam.
It run successfully.
However, when I use paraview to see the result data, I can't find any options to visualize the particle data. What should I do to achieve that?

Thanks.

eelcovv March 19, 2012 08:56

Use 'ExtractBlock' to select the lagrangian cloud. Then you can add glyphs at the selected particle positions.

Alternatively: use the particleTracks utility to create tracks from the position. Each track is solved as a vtk file, which you can directly read into paraview. An improved version of particleTracks can be found in my other post
http://www.cfd-online.com/Forums/ope...ble-flows.html
It removes a bug and also more output options have been added.

Regards
Eelco

leefei March 20, 2012 10:21

Hi Eelco,

I used 'ExtractBlock' and selected lagrangian cloud. And then I tried to glyth the cloud as 'sphere' with particle diameter. However I could not do that, because I can't find any parameter in 'Scalars' and also in 'Vectors'.
I run the tut case hopperInitialState as it without any change.

The same problem was also found for the tut case hopperEmptying. And in that case, I could not even found lagrangian cloud in 'ExtractBlock' .

Thanks,

Lee

leefei March 21, 2012 05:06

I found the problem. There is no particle in timestep 0. When I forward the timestep, the particles appears.

However, for the case hopperEmptying, there is still no particles at any step.

eelcovv April 2, 2012 09:24

May be I should remark that for the Glyphs filter in order for the 'Scalars' selection list to become availble, you should change 'Scale Mode' from 'Vector' to 'Scalar' Then the list of scalars becomes avaible and you can select for instance 'd'. But I guess you have found it already.


All times are GMT -4. The time now is 03:30.