CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Pre-Processing (http://www.cfd-online.com/Forums/openfoam-pre-processing/)
-   -   buoyantSimpleFoam error (http://www.cfd-online.com/Forums/openfoam-pre-processing/115223-buoyantsimplefoam-error.html)

Grimoli March 26, 2013 10:27

buoyantSimpleFoam error
 
Guys im doing a heat transfer case using buoyantsimplefoam Solver ,however when i type the command :buoyantSimpleFoam

Im getting the certain error :








--> FOAM FATAL ERROR:
Attempt to return primitive entry ITstream : /home/oem/OpenFOAM/gabriel-2.1.1/run/tutorials/pipe/constant/thermophysicalProperties::mixture, line 22, IOstream: Version 2.0, format ASCII, line 0, OPENED, GOOD
primitiveEntry 'mixture' comprises
on line 22 the word 'air'
on line 22 the label 1
on line 22 the doubleScalar 28.96
on line 22 the doubleScalar 1004.4
on line 22 the label 0
on line 22 the doubleScalar 1.831e-05
on line 22 the doubleScalar 0.705
as a sub-dictionary

From function const dictionary& primitiveEntry::dict() const
in file db/dictionary/primitiveEntry/primitiveEntry.C at line 159.

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::error::abort() at ??:?
#2 Foam::primitiveEntry::dict() const at ??:?
#3 Foam::dictionary::subDict(Foam::word const&) const at ??:?
#4 Foam::hPsiThermo<Foam::pureMixture<Foam::constTran sport<Foam::specieThermo<Foam::hConstThermo<Foam:: perfectGas> > > > >::hPsiThermo(Foam::fvMesh const&) at ??:?
#5 Foam::basicPsiThermo::addfvMeshConstructorToTable< Foam::hPsiThermo<Foam::pureMixture<Foam::constTran sport<Foam::specieThermo<Foam::hConstThermo<Foam:: perfectGas> > > > > >::New(Foam::fvMesh const&) at ??:?
#6 Foam::basicPsiThermo::New(Foam::fvMesh const&) at ??:?
#7
at ??:?
#8 __libc_start_main in "/lib/x86_64-linux-gnu/libc.so.6"
#9
at ??:?
Aborted (core dumped)






What should I do about it??

fredo490 March 26, 2013 11:38

It looks like there is a problem with your declaration in the "thermophysicalProperties" which is in the Constant folder. Maybe the "thermoType" doesn't match your settings.

Grimoli March 26, 2013 11:50

HEy guys i found the error.It was because i was using old version of thermophysicalProperties.I copied the new version and it ran alright. :)


All times are GMT -4. The time now is 07:18.