CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Pre-Processing

OpenFOAM 13 FoamX libelfso0 and Fedora Core 4

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 31, 2006, 02:45
Default I've just upgraded to 1.3, on
  #1
New Member
 
Charles Crosby
Join Date: Mar 2009
Location: Cape Town, Western Cape, South Africa
Posts: 5
Rep Power: 8
crosby is on a distinguished road
I've just upgraded to 1.3, on an X86_64 FC4 system, and had trouble with starting FoamX, due to a missing libelf.so.0 It seems as if there is difference in the way that Fedora and Redhat impliments libelf compared to everybody else. libelf.so.0 can be obtained from http://www.mr511.de/software/ in source form, and it seems to fix the problem.
crosby is offline   Reply With Quote

Old   March 31, 2006, 12:45
Default I had the same problem on my F
  #2
New Member
 
Steffen Jahnke
Join Date: Mar 2009
Posts: 14
Rep Power: 8
steja is on a distinguished road
I had the same problem on my FC5 x86_64 (Xeon EM64T) system and for some reasons "nsd" is looking for libelf.so.0.
=============
$ FoamX
Starting NameServer with inet:phorkys.uni-rostock.de:1234 ...
nsd: error while loading shared libraries: libelf.so.0: cannot open shared object file: No such file or directory
=============

I tried to install libelf package but it did not show up a libelf.so.0. Instead I just created a link to /usr/lib64/libelf.so which obviously solved the problem.
steja is offline   Reply With Quote

Old   March 31, 2006, 12:55
Default I had the same problem with Fe
  #3
Senior Member
 
Francesco Del Citto
Join Date: Mar 2009
Location: Zürich Area, Switzerland
Posts: 215
Rep Power: 9
fra76 is on a distinguished road
I had the same problem with Fedora Core 3 32bit and in Fedora Core 5 64bit.
I've resolved in a different way, on FC3: as root

# cd /usr/lib
# ln -s libelf.so.1 libelf.so.0

I guess that in FC5 one should change directory to /usr/lib64, but I haven't tried yet.
That's all!
fra76 is offline   Reply With Quote

Old   March 31, 2006, 22:02
Default wiht RHAS4 i had met the same
  #4
New Member
 
ddydai
Join Date: Mar 2009
Posts: 3
Rep Power: 8
ddydai is on a distinguished road
wiht RHAS4 i had met the same problem=============
$ FoamX
Starting NameServer with inet:phorkys.uni-rostock.de:1234 ...
nsd: error while loading shared libraries: libelf.so.0: cannot open shared object file: No such file or directory
=============
and followed upstairs ,building a link between successfully solved the problem.
ddydai is offline   Reply With Quote

Old   April 11, 2006, 15:27
Default I had the same problem with Fe
  #5
New Member
 
Dario Isola
Join Date: Mar 2009
Posts: 2
Rep Power: 0
bucky83 is on a distinguished road
I had the same problem with Fedora 5. I've tried this:

# cd /usr/lib
# ln -s libelf.so.1 libelf.so.0

and the problem changed, to be:

[Dario@localhost ~]$ FoamX
Starting NameServer with inet:localhost.localdomain:1234 ...
Starting FoamX Host Browser with inet:localhost.localdomain:1234 ...
FoamXHostBrowser: error while loading shared libraries: /home/Dario/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libFoamX.so: cannot restore segment prot after reloc: Permission denied
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 29989).

Does anybody know what kind of touble is this?

DARIO
bucky83 is offline   Reply With Quote

Old   April 18, 2006, 14:01
Default Missing libelf: another so
  #6
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Missing libelf:

another solution is to reconfigure and recompile mico itself so it doesn't include libelf. From $FOAM_SRC/Allwmake:

cd $MICO_PATH
gmake distclean
./configure --prefix=$MICO_ARCH_PATH --disable-shared --without-x
gmake
gmake install
gmake distclean
mattijs is offline   Reply With Quote

Old   April 19, 2006, 00:56
Default Hi, Mattijs I am a newbie t
  #7
New Member
 
berry
Join Date: Mar 2009
Location: Wuhan, Hubei, China
Posts: 1
Rep Power: 0
berry_hust is on a distinguished road
Hi, Mattijs

I am a newbie to Linux system. I have the same Missing libelf problem on RedHat 9.0 whn I run FoamX. However, when I go to the mico directory
/OpenFOAM/OpenFOAM-1.3/src/mico-2.3.11
and gmake distclean, I get this errors:
gmake:
*** No rule to make target `distclean'. Stop.

Could you help me with that stuff?
berry_hust is offline   Reply With Quote

Old   April 20, 2006, 05:46
Default That message tells you there i
  #8
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
That message tells you there is nothing to be cleaned. Just issue the other commands.
mattijs is offline   Reply With Quote

Old   April 21, 2006, 09:03
Default I am having the similar proble
  #9
liuxi
Guest
 
Posts: n/a
I am having the similar problem when I installed FOAM on AMD64 with RedHat system.

I followed Mattijs' suggestion, but got the following error message:

./configure --prefix=$MICO_ARCH_PATH --disable-shared --without-x
loading cache ./config.cache
checking for extra include and lib directories...
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking build system type... x86_64-unknown-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc -m64 -fPIC -m64) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.

Can You help me with this issue?

Thanks!
  Reply With Quote

Old   April 21, 2006, 09:16
Default Hello John, The message
  #10
Senior Member
 
Martin Beaudoin
Join Date: Mar 2009
Posts: 330
Rep Power: 13
mbeaudoin will become famous soon enough
Hello John,

The message

configure: error: installation or configuration problem: C compiler cannot create executables.

simply means that either gcc cannot compile a little test case, or that it cannot link the same little test case.

A fuller description or cause of the error is usually mentionned in the file config.log, generated by the invocation of configure.

My bet is that you've specified the compilation option -m64, but you did not modify the default path for the library, which should be something like /usr/lib64 or something like this...

Good luck.

Martin
mbeaudoin is offline   Reply With Quote

Old   May 3, 2006, 10:19
Default Hi, Martin, I am sorry the
  #11
liuxi
Guest
 
Posts: n/a
Hi, Martin,

I am sorry the late response. Here is the error message in configure.log. Can you help me further?

Thanks!

John

------------------------------------------------

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:1162: checking host system type
configure:1183: checking target system type
configure:1201: checking build system type
configure:1304: checking for gcc
configure:1417: checking whether the C compiler (gcc -m64 -fPIC -m64) works
configure:1433: gcc -o conftest -m64 -fPIC -m64 conftest.c 1>&5
/usr/bin/ld: unrecognized option '--as-needed'
/usr/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
configure: failed program was:

#line 1428 "configure"
#include "confdefs.h"

main(){return(0);}
  Reply With Quote

Old   May 4, 2006, 00:15
Default Hello John, You are using t
  #12
Senior Member
 
Martin Beaudoin
Join Date: Mar 2009
Posts: 330
Rep Power: 13
mbeaudoin will become famous soon enough
Hello John,

You are using the pre-compiled version of gcc from OpenCFD.

I had the exact same problem with the pre-compiled gcc compiler released with OpenFOAM 1.2 on my SuSE 9.1 OS last year.

From the error message

/usr/bin/ld: unrecognized option '--as-needed'

we can see that your workstation's local version of ld is not compatible with the pre-compiled compiler supplied by OpenCFD. And they need to be compatible...

This is normal; basically, when you compile gcc on a given workstation, the configure script will "explore" the capabilities of the local linker "ld" before building the Makefiles and such.

If the configure script discovers that your local version of "ld" supports new options or command line parameters (like the --as-needed option), it will configure gcc to use them.

Now, when you try to use that pre-compiled compiler on an older environment or OS, with an older version of "ld" that is not recognizing the brand new "ld" option like --as-needed, you will get the kind of problem you are experiencing.

This is why, now, I always recompile OpenFOAM and its companion tools when a new release is made available: OpenFOAM, gcc, paraview, etc. OpenCFD is simply compiling the pre-compiled package for OpenFOAM on a newer OS than the one I am using on my workstation.

Of course, another solution would be to always keep my OS up-to-date with the latest version of SuSE or RedHat available. This is not a practical solution for me, although I would love to be able to "tag along" in this area .

On the other hand, maybe there is a command line option for instructing g++/gcc no to try to use the brand new "ld" options. I will investigate that possibility and report to this forum if I find any pointers on that idea.

So, the easiest solution for you and me: you need to recompile gcc locally for your workstation.

For the details, check out this HowTo on the OpenFOAM Wiki:

http://openfoamwiki.net/index.php/Howto_compile_O penFOAM

There is a section explaining how to recompile gcc.

Enjoy,

Martin
mbeaudoin is offline   Reply With Quote

Old   May 4, 2006, 17:53
Default Martin, I did try to recomp
  #13
liuxi
Guest
 
Posts: n/a
Martin,

I did try to recompile gcc and FOAM and was not successful. I will put it in another thread under the installation group.

Thank you for the patience.

John
  Reply With Quote

Old   July 26, 2006, 07:08
Default Hi All, I have had the same
  #14
morten
Guest
 
Posts: n/a
Hi All,

I have had the same problem on two PC running Fedora Core 6 and SUSE 10.1 respectively. I was able to solve the problem by recompiling the libelf 0.8.8 library from www.mr511.de/software as described by Charles Crosby earlier in this thread. As default the libelf script dropped the binaries in /usr/local/lib - so what was left was only to provide a link to the binary from the /lib library which OpenFOAM seems to use as default.

Morten Lybech Thĝgersen
  Reply With Quote

Old   October 21, 2006, 19:00
Default Hi Morten, I also had the s
  #15
New Member
 
Makoto Ueno
Join Date: Mar 2009
Location: Japan
Posts: 9
Rep Power: 8
ueno is on a distinguished road
Hi Morten,

I also had the same problem on my PC and recompiled the libelf library.
But, I prefer to configure the library as follows,

./configure --prefix=$FOAM_USER_LIBBIN/../linuxGcc4DPOpt --exec-prefix=$FOAM_USER_LIBBIN/../linuxGcc4DPOpt --libdir=$FOAM_USER_LIBBIN/../linuxGcc4DPOpt --without-x

$FOAM_USER_LIBBIN could be replaced with $FOAM_LIB

Then "make install" would make the things nice.
With this configuration, you don't need to provide another link to OpenFOAM.
FoamX can automatically find the PATH to the libelf.so.0.

Makoto
ueno is offline   Reply With Quote

Old   November 11, 2006, 02:03
Default Hi All I have same problem wh
  #16
Senior Member
 
Marhamat Zeinali
Join Date: Mar 2009
Location: Tehran, Tehran, iran
Posts: 107
Rep Power: 8
marhamat is on a distinguished road
Hi All
I have same problem whit FoamX running . I chenged linux from Redhat 9.0 to Enterprise.
=============
$ FoamX
Starting NameServer with inet:localhost.localdomain:1234 ...
nsd: error while loading shared libraries: libelf.so.0: cannot open shared object file: No such file or directory
=============
With ussing
# cd /usr/lib
# ln -s libelf.so.1 libelf.so.0
Nothing chenged.

what is incorrect?

Regards
Marhamat
marhamat is offline   Reply With Quote

Old   November 13, 2006, 04:04
Default This is probably because you d
  #17
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
This is probably because you don't have libelf on your system at all.
Check this:
home/dragosm> rpm -q -a | grep libelf
libelf-0.8.5-35
home/dragosm> rpm -q -l libelf-0.8.5-35
/usr/include/libelf
/usr/include/libelf/elf_repl.h
/usr/include/libelf/gelf.h
/usr/include/libelf/libelf.h
/usr/include/libelf/nlist.h
/usr/include/libelf/sys_elf.h
/usr/lib64/libelf.a
/usr/lib64/libelf.so
/usr/lib64/libelf.so.0
/usr/lib64/libelf.so.0.8.5
/usr/share/doc/packages/libelf
/usr/share/doc/packages/libelf/COPYING.LIB
/usr/share/doc/packages/libelf/ChangeLog
/usr/share/doc/packages/libelf/README
/usr/share/doc/packages/libelf/VERSION
/usr/share/locale/de/LC_MESSAGES/libelf.mo

I bet, grep won't find anything in the first place!

Dragos
dmoroian is offline   Reply With Quote

Old   November 14, 2006, 06:34
Default Hi Dragos Thanks for your h
  #18
Senior Member
 
Marhamat Zeinali
Join Date: Mar 2009
Location: Tehran, Tehran, iran
Posts: 107
Rep Power: 8
marhamat is on a distinguished road
Hi Dragos

Thanks for your help
My promlem solved successfuly

Best regards
marhamat is offline   Reply With Quote

Old   December 4, 2006, 06:14
Default In suse, you can go into Yast
  #19
Member
 
nicolas
Join Date: Mar 2009
Location: Glasgow
Posts: 42
Rep Power: 8
nico765 is on a distinguished road
In suse, you can go into Yast ans just install libelf.
nico765 is offline   Reply With Quote

Old   September 17, 2007, 23:30
Default Hi, I tried a method as som
  #20
New Member
 
gulitom
Join Date: Mar 2009
Posts: 3
Rep Power: 8
gulitom is on a distinguished road
Hi,

I tried a method as someone told me, but it shows as follows:

[guli@localhost guli]$ cd $FOAM_LIBBIN
[guli@localhost linuxGcc4DPOpt]$ rpm -q -a | grep libelf
elfutils-libelf-0.76-3
[guli@localhost linuxGcc4DPOpt]$ rpm -q -l elfutils-libelf-0.76-3
/usr/lib/libelf-0.76.so
/usr/lib/libelf.so.1
[guli@localhost linuxGcc4DPOpt]$ ln -s /usr/lib/libelf.so.1 libelf.so.0
[guli@localhost linuxGcc4DPOpt]$ FoamX
Starting NameServer with inet:localhost.localdomain:1234 ...
Starting FoamX Host Browser with inet:localhost.localdomain:1234 ...
FoamXHostBrowser: /lib/tls/libc.so.6: version `GLIBC_2.3.4' not found (required
by FoamXHostBrowser)
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 6628).

Can anyone help?
gulitom is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FoamX libelfso0 nunoinlux OpenFOAM Bugs 6 September 11, 2007 20:13
fluent on fedora core 6 Jeferson FLUENT 7 February 9, 2007 15:43
FoamX Error after upgrade to Fedora Core 6 philippose OpenFOAM Installation 5 October 31, 2006 13:36
FoamX libelfso0 mockealm OpenFOAM Installation 6 June 29, 2006 15:37
FEDORA core 2 and FLUENT tuks FLUENT 2 July 13, 2005 00:23


All times are GMT -4. The time now is 09:50.