CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Pre-Processing

FoamX Startup Error libXpso6

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   November 9, 2007, 16:38
Default Hello, I have installed Ope
Posts: n/a

I have installed OpenFOAM on an X86_64 machine running RHEL 5 but cannot seem to get FoamX running. I have successfully created symbolic links for,, and However, I have not been able to figure out how to resolve the following error (which I believe is related to libX.s0.6 symbolic link).

[cmerrill@penguin ~]$ FoamX
Starting NameServer with inet:penguin.ara.wan:1234 ...
Starting FoamX Host Browser with inet:penguin.ara.wan:1234 ...
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.4.1 |
| \ / A nd | Web: |
| \/ M anipulation | |

Exec : FoamXHostBrowser
Date : Nov 09 2007
Time : 15:20:34
Host : penguin.ara.wan
PID : 3688
Root :
Case :
Nprocs : 1
HostBrowser running.....
Setting LANG to en_EN
Using jar /home/cmerrill/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/Foam X/lib/FoamX.jar
Using jar /home/cmerrill/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/Foam X/lib/jlfgr-1_0.jar
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/cmerrill/OpenFOAM/linux64/j2sdk1.4.2_05/jre/lib/i386/ cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1586)
at java.lang.ClassLoader.loadLibrary( :1503)
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at Method)
at sun.awt.NativeLibLoader.loadLibraries(NativeLibLoa
at sun.awt.DebugHelper.<clinit>(
at java.awt.Component.<clinit>(
/home/cmerrill/OpenFOAM/OpenFOAM-1.4.1/bin/runFoamXHB: line 139: 3688 Killed FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 3684).

Any suggestions? I am a newbie. Thank you.
  Reply With Quote

Old   November 9, 2007, 19:39
Default Search the forum for posts tha
Senior Member
Srinath Madhavan (a.k.a pUl|)
Join Date: Mar 2009
Location: Edmonton, AB, Canada
Posts: 700
Rep Power: 12
msrinath80 is on a distinguished road
Search the forum for posts that suggest ways to solve the issue.

msrinath80 is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
GAMBIT STARTUP error Farhat FLUENT 3 February 9, 2010 14:52
FoamX error lawrencelkl OpenFOAM Installation 5 May 23, 2008 01:29
FoamX libXpso6 wrong ELF class error abanerj3 OpenFOAM Pre-Processing 2 May 18, 2008 15:32
FoamX error derath OpenFOAM Pre-Processing 2 April 25, 2007 05:51
Gambit startup error: cannot be found Patrice Guay FLUENT 5 August 10, 2005 13:03

All times are GMT -4. The time now is 17:25.