CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Pre-Processing

Problem with running FoamX in a distributed environment

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   March 28, 2007, 05:42
Default Hi All, I am having a prob
Posts: n/a
Hi All,
I am having a problem and will be truly grateful if someone can help me.

I have 2 machines A & B, A running Foam on Fedora 6 (32-bit) and B running Foam on SuSE 10 (64 bit). I ran the runFoamXHB script on B (i.e started name service on B) and tried to start FoamX on A to connect to machine B's name service. The FoamX GUI starts (with no host details on it) and I get an error "Default Name service could not be contacted"

I have been reading through a lot of posts and did what was mentioned there but still cannot solve the problem. What I did:

1. copied ns.ref in machine B to machine A (directory../OpenFOam/...Apps/FoamX/)
2. changed the FoamXClient.cfg in both A and B to point Host = B and port = 1234.
3. changed /etc/hosts on both machines to include both own and each other's hostnames
4. no firewall running on both machines.
5. When all the above still did not solve the problem, I changed the port number to 123456...but still have same problem..
6. I ran nsd on both A and B locally and a sample CORBA server and client program on the same machine can see and connect to it.
7. I can telnet, ftp from both machines.

Now I am really stuck and dont know what other options to try....can someone PLEASE HELP.

Thanks a lot,
  Reply With Quote

Old   March 28, 2007, 17:11
Default Do an iordump/iordecode on tha
Super Moderator
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Do an iordump/iordecode on that ns.ref. Pick up B's fully resolved name from there and see if you can telnet to the nsd using that:

telnet fully-resolved-name 1234
mattijs is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding FoamX running Kindly help out hariya03 OpenFOAM Pre-Processing 0 April 18, 2008 04:26
Problem running FoamX ianz8802 OpenFOAM Installation 11 March 23, 2007 12:22
Running FoamX vivekjoshi OpenFOAM Installation 0 November 5, 2006 17:13
problem in running FoamX in Open FOAM Gaurav Main CFD Forum 3 May 10, 2006 05:06

All times are GMT -4. The time now is 18:36.