CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Programming & Development

Initialisation problem with interFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 2, 2013, 06:52
Default Initialisation problem with interFoam
  #1
Member
 
belkadi
Join Date: May 2013
Location: France
Posts: 31
Rep Power: 4
belkadi is on a distinguished road
Dear Foamer,

I'm trying to use the interFoam to simulate the mixing of two fluids.
I've uploaded the test case:
1. When running the blockMesh there is no errors.
2. After that for runing the setFields (no errors) : please do not forget to do the cp0/alph1.org 0/alpha1 before runing the setFields
3. runing interFoam : I think that there is some issues with the initialisation or may be the mesh, but I could not figure out what it is
exaclty : the error message is :

----------------------------

Create mesh for time = 0
 
PIMPLE: Operating solver in PISO mode
Reading field p_rgh
Reading field U
Reading/calculating face flux field phi
Reading transportProperties
Selecting incompressible transport model Newtonian
Selecting incompressible transport model Newtonian
Selecting turbulence model type laminar
Reading g
Calculating field g.h
No finite volume options present
time step continuity errors : sum local = 1.47059e+292, global = 1.47059e+292, cumulative = 1.47059e+292
DICPCG: Solving for pcorr, Initial residual = 1, Final residual = 5.19085e-11, No Iterations 66
time step continuity errors : sum local = 7.63557e+281, global = -5.03459e+279, cumulative = 1.47059e+292
Courant Number mean: 2.23052e+293 max: 1.58306e+294
Starting time loop
Courant Number mean: 0.0704495 max: 0.5
Interface Courant Number mean: 0 max: 0
deltaT = 3.15844e-298
Time = 3.15844e-298
MULES: Solving for alpha1
Phase-1 volume fraction = 0.939827 Min(alpha1) = -0.114728 Max(alpha1) = 1
MULES: Solving for alpha1
Phase-1 volume fraction = 0.938477 Min(alpha1) = -0.229443 Max(alpha1) = 1
#0 Foam::error:rintStack(Foam::Ostream&) at ??:?
#1 Foam::sigFpe::sigHandler(int) at ??:?
#2 Uninterpreted:
 
---------------------------------------
As you can see the sum local is too high, I think taht in the beginig of calculation some dividing by zero occured
Honestly, I don't know how to fix it, do you have any ideas
it would be really appreciated !

Many thanks

Krimo
Attached Files
File Type: gz mesh_problem_v2.tar.gz (3.2 KB, 1 views)
belkadi is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
interFoam rotating cylinder pressure BC problem chrisb2244 OpenFOAM Running, Solving & CFD 1 August 12, 2013 01:37
interFoam problem: Movement in wrong direction u2947 OpenFOAM Running, Solving & CFD 0 June 17, 2013 06:29
Parallel running of 3D multiphase turbulence model (unknown problem!!) MOHAMMAD67 OpenFOAM Running, Solving & CFD 5 November 11, 2011 01:12
Problem: tetrahedral mesh and interFoam = bad results ? querdynamik OpenFOAM Running, Solving & CFD 0 June 4, 2010 09:43
Initialisation problem Turbo tool CFX-Post Toralf CFX 0 February 13, 2008 06:44


All times are GMT -4. The time now is 23:27.