CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Programming & Development

layer addition deletion in parallel

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 9, 2010, 05:33
Default layer addition deletion in parallel
  #1
New Member
 
Kedar Jathar
Join Date: Jan 2010
Posts: 7
Rep Power: 7
kedarj14 is on a distinguished road
Hello :

I am trying to use layer addition deletion in parallel. The case is working in serial. The case runs in parallel too, however I am not able to post process it properly.

1. Using reconstructPar
reconstructPar utility works till the time directory until the cell count is same as original. Once a cell layer is added the reconstruct par fails. It searches for a file pointProcAddressing, which is not available in the results.

2. ParaFoam
ParaFoam can read the mesh in the individual processor directories. It also shows that the layer are added and deleted. However it crashes if I try to read the pressure and velocity fields.

Has anyone encountered this problem before ? Any solutions, suggestions will be very helpful.

Thanks
Kedar
kedarj14 is offline   Reply With Quote

Old   April 20, 2011, 06:33
Default
  #2
New Member
 
Kedar Jathar
Join Date: Jan 2010
Posts: 7
Rep Power: 7
kedarj14 is on a distinguished road
Quote:
Originally Posted by kedarj14 View Post
Hello :

I am trying to use layer addition deletion in parallel. The case is working in serial. The case runs in parallel too, however I am not able to post process it properly.

1. Using reconstructPar
reconstructPar utility works till the time directory until the cell count is same as original. Once a cell layer is added the reconstruct par fails. It searches for a file pointProcAddressing, which is not available in the results.

2. ParaFoam
ParaFoam can read the mesh in the individual processor directories. It also shows that the layer are added and deleted. However it crashes if I try to read the pressure and velocity fields.

Has anyone encountered this problem before ? Any solutions, suggestions will be very helpful.

Thanks
Kedar
We need to use reconstructParMesh before running reconstructPar
kedarj14 is offline   Reply With Quote

Old   December 20, 2012, 02:45
Default
  #3
u22
Member
 
Anthony Nitski
Join Date: Aug 2009
Location: Earth
Posts: 34
Rep Power: 7
u22 is on a distinguished road
This is old post, but i have question. What solver and which OF version you used for layerAR? For me, in 1.6ext I can not get to work adding layers in dieselEngineDyMFoam....So maybe i must to downgrade...
u22 is offline   Reply With Quote

Reply

Tags
layer addition deletion, mdm, parallel, reconstructpar

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Script to Run Parallel Jobs in Rocks Cluster asaha OpenFOAM Running, Solving & CFD 12 July 4, 2012 22:51
Trimmer & prism layer peresah STAR-CCM+ 6 October 6, 2009 14:39
How to use the engine solvers with layer addition and removal francesco OpenFOAM Running, Solving & CFD 2 March 19, 2009 04:29
errors Fahad Main CFD Forum 0 March 23, 2004 14:20
Parallel Computing Classes at San Diego Supercomputer Center Jan. 20-22 Amitava Majumdar Main CFD Forum 0 January 5, 1999 13:00


All times are GMT -4. The time now is 23:28.