CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Programming & Development

fixedMeanValue "namespace" error

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 10, 2010, 05:04
Unhappy fixedMeanValue "namespace" error
  #1
Member
 
Join Date: Sep 2010
Posts: 36
Rep Power: 7
siddharameshwara is on a distinguished road
Hi to all,

I tried to add fixed MeanValue boundary condition to my cavitatingFoam but when i execute it using wmake it is showing the following error

fixedMeanValueFvPatchField.H:41: error: ‘namespace’ definition is not allowed here

Can anybody help me in this regard

Thanks
siddharameshwara is offline   Reply With Quote

Old   December 11, 2010, 08:38
Default
  #2
Member
 
Usit McCarra
Join Date: Oct 2010
Posts: 51
Blog Entries: 2
Rep Power: 6
McCarra is on a distinguished road
Hello,

If I'm not mistaken, you should apply the boundary conditions on the 0 folder of your case. It makes no sense to compile boundary conditions since they are set at "user level".
Which is the case you are running? Is it a tutorial?

Depending on the parameter you are trying to set (U, p,...) there are different options of patchField types (fixedValue, fixedGradient, fixedNormalSlip...).

Regards
McCarra is offline   Reply With Quote

Old   December 13, 2010, 04:00
Smile
  #3
Member
 
Join Date: Sep 2010
Posts: 36
Rep Power: 7
siddharameshwara is on a distinguished road
Quote:
Originally Posted by McCarra View Post
Hello,

If I'm not mistaken, you should apply the boundary conditions on the 0 folder of your case. It makes no sense to compile boundary conditions since they are set at "user level".
Which is the case you are running? Is it a tutorial?

Depending on the parameter you are trying to set (U, p,...) there are different options of patchField types (fixedValue, fixedGradient, fixedNormalSlip...).

Regards
Hi dude,

I am using tutorial. But, now i solved the problem. I had some problem with permissions. Now everything is ok. Any how thanks for your reply,

Cheers.
siddharameshwara is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
GroovyBC the dynamic cousin of funkySetFields that lives on the suburb of the mesh gschaider OpenFOAM 300 October 29, 2014 19:00
Errors running allwmake in OpenFOAM141dev with WM_COMPILE_OPTION%3ddebug unoder OpenFOAM Installation 11 January 30, 2008 21:30
Compiling Netgen on Fedora Core is driving me crazy jango Open Source Meshers: Gmsh, Netgen, CGNS, ... 3 November 9, 2007 14:29
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 17:51
user defined function cfduser CFX 0 April 29, 2006 10:58


All times are GMT -4. The time now is 17:57.