CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Programming & Development

error in eclipse

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 22, 2010, 05:08
Default error in eclipse
  #1
New Member
 
linda zhang
Join Date: Dec 2010
Posts: 7
Rep Power: 6
Linda is on a distinguished road
I tried to test a solver according to

http://openfoamwiki.net/index.php/Ho...M_with_Eclipse

After I imported the pitzDaily project in eclipse and run the programme, there is always an error

"/OpenFOAM/OpenFOAM-1.7.1/applications/bin/linuxGccDPDebug/simpleFoam: error while loading shared libraries: libincompressibleTurbulenceModel.so: cannot open shared object file: No such file or directory".

Could you please help about it?

Thanks
Linda
Linda is offline   Reply With Quote

Old   December 22, 2010, 05:16
Default
  #2
Senior Member
 
Matthias Voß
Join Date: Mar 2009
Location: Berlin, Germany
Posts: 446
Rep Power: 11
mvoss is on a distinguished road
hey,

did you set up the make/files properly?

neewbie
mvoss is offline   Reply With Quote

Old   December 22, 2010, 05:20
Default
  #3
New Member
 
linda zhang
Join Date: Dec 2010
Posts: 7
Rep Power: 6
Linda is on a distinguished road
How to setup the make/file?

sorry i am a newbie.
Linda is offline   Reply With Quote

Old   December 22, 2010, 05:24
Default
  #4
Senior Member
 
Matthias Voß
Join Date: Mar 2009
Location: Berlin, Germany
Posts: 446
Rep Power: 11
mvoss is on a distinguished road
so am i...
sorry, i meant the make/options.

there has to be smth. like
Code:
EXE_INC = \
...
EXE_LIBS = \
...
    -lcompressibleTurbulenceModel \
...
mvoss is offline   Reply With Quote

Old   December 22, 2010, 21:23
Default
  #5
New Member
 
linda zhang
Join Date: Dec 2010
Posts: 7
Rep Power: 6
Linda is on a distinguished road
Do you mean building the openfoam sources? I use the script
'./Allwmake'. It should build everything.

And I execute the foamInstallationTest script and got

'Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/ylz/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/ylz/OpenFOAM/ylz-1.7.1 yes no
$WM_THIRD_PARTY_DIR /home/ylz/OpenFOAM/ThirdParty-1.7.1 yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/ylz/OpenFOAM/OpenFOAM-1.7.1 yes yes yes

$FOAM_APPBIN ...7.1/applications/bin/linuxGccDPDebug yes yes yes
$FOAM_SITE_APPBIN ...nFOAM/site/1.7.1/bin/linuxGccDPDebug no no
$FOAM_USER_APPBIN ...7.1/applications/bin/linuxGccDPDebug no no
$WM_DIR /home/ylz/OpenFOAM/OpenFOAM-1.7.1/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.7.1/lib/linuxGccDPDebug yes yes yes
$FOAM_SITE_LIBBIN ...nFOAM/site/1.7.1/lib/linuxGccDPDebug no no
$FOAM_USER_LIBBIN ...enFOAM/ylz-1.7.1/lib/linuxGccDPDebug no no
$MPI_ARCH_PATH ...7.1/platforms/linuxGcc/openmpi-1.4.1 yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.4.5 /usr/bin/gcc
gzip 1.3.12 /bin/gzip
tar 1.23 /bin/tar
icoFoam 1.7.1 ...penFOAM-1.7.1/applications/bin/linuxGccDPDebug/icoFoam
-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

Critical systems ok.

done.
'

So do you think it is the problem from the openfoam or setup of eclipse?

regards
yali
Linda is offline   Reply With Quote

Old   December 22, 2010, 22:23
Default
  #6
New Member
 
linda zhang
Join Date: Dec 2010
Posts: 7
Rep Power: 6
Linda is on a distinguished road
when I use 'wmake' to compile, i run into such problem:
'
ylz@ubuntu:~/OpenFOAM/OpenFOAM-1.7.1$ wmake Make/linux64Gcc4DPOpt/<object>.o
bash: object: No such file or directory
ylz@ubuntu:~/OpenFOAM/OpenFOAM-1.7.1$ wmake libso
wmake error: 'Make' directory does not exist
'
Are they related to the problem resulted from the eclipse?
Linda is offline   Reply With Quote

Old   December 23, 2010, 02:13
Default
  #7
New Member
 
linda zhang
Join Date: Dec 2010
Posts: 7
Rep Power: 6
Linda is on a distinguished road
I checked the make/options in the simplefoam;

"EXE_INC = \
-I$(LIB_SRC)/turbulenceModels \
-I$(LIB_SRC)/turbulenceModels/incompressible/RAS/RASModel \
-I$(LIB_SRC)/transportModels \
-I$(LIB_SRC)/transportModels/incompressible/singlePhaseTransportModel \
-I$(LIB_SRC)/finiteVolume/lnInclude

EXE_LIBS = \
-lincompressibleTurbulenceModel \
-lincompressibleRASModels \
-lincompressibleTransportModels \
-lfiniteVolume
"

Is it correct? Please advise. 3x
Linda is offline   Reply With Quote

Old   January 3, 2011, 04:00
Default
  #8
Senior Member
 
Matthias Voß
Join Date: Mar 2009
Location: Berlin, Germany
Posts: 446
Rep Power: 11
mvoss is on a distinguished road
hi,

seems okay to me.
Are you trying to create a library ? Did you choose the right kind of project ("..with Makefile") while setting up the case in eclipse?

neewbie
mvoss is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eclipse for OpenFOAM AMahrla OpenFOAM Programming & Development 108 February 27, 2015 09:51
error in eclipse inginer OpenFOAM 2 July 21, 2010 09:09


All times are GMT -4. The time now is 05:25.