CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Programming & Development (http://www.cfd-online.com/Forums/openfoam-programming-development/)
-   -   WM_COMPILE=Debug, gdb reverse-step breaks (http://www.cfd-online.com/Forums/openfoam-programming-development/90714-wm_compile-debug-gdb-reverse-step-breaks.html)

tomislav_maric July 19, 2011 08:16

WM_COMPILE=Debug, gdb reverse-step breaks
 
Has anyone had success with the reverse-* commands from the gdb 7?

This is what happens to me:

Code:

(gdb) reverse-step
Target multi-thread does not support this command.
(gdb)

I know that I need to turn off the following (gdb message):

Code:

[Thread debugging using libthread_db enabled]
If someone can save me some digging time for the linker option for libthread_db, I would really appreciate it. ;)

elvis July 21, 2011 09:30

Hi,
i maybe completely wrong, but I read at http://openfoamwiki.net/index.php/Ho...M_with_Eclipse
=>GNU Debugger (gdb) version: 6.8
Please be careful choosing the right gdb version! In gdb 7.x a bug seems to occur while debugging and monitoring the variables.

So this might be case for you as well.

Can you try the older gdb 6 version?

tomislav_maric July 21, 2011 09:43

Quote:

Originally Posted by elvis (Post 316932)
Hi,
i maybe completely wrong, but I read at http://openfoamwiki.net/index.php/Ho...M_with_Eclipse
=>GNU Debugger (gdb) version: 6.8
Please be careful choosing the right gdb version! In gdb 7.x a bug seems to occur while debugging and monitoring the variables.

So this might be case for you as well.

Can you try the older gdb 6 version?

Hi elvis! Thanks for the answer,

however : I'm not using Eclipse, I'm running on Vim + gdb in the console. I'm just keeping things simple, because I'm stupid (KISS). :D

There's no bug, it's just that the reverse-* commands in gdb do not work well with multithreading. I need to see how to exclude libthread from being linked during compilation. I have tried setting the path to libthread in gdb t to the wrong value, but then it got reverted to the system lib. I'll probably dig into this eventually, it would just be nice if I don't have to do so, if someone has already found a way to use reverse-* without libthread.

Older version: only gdb 7.* support reverse-* commands.


All times are GMT -4. The time now is 14:31.