CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   Parallel motorBike LES computing problem. (http://www.cfd-online.com/Forums/openfoam-solving/106135-parallel-motorbike-les-computing-problem.html)

xiexiehezuo August 20, 2012 09:57

Parallel motorBike LES computing problem.
 
I ran the pisoFoam LES motorBike tutorial case on the cluster. It worked fine. Using the default setup, this job finished in about 7 hours on 8 cores. However, after I change a few parameters, it gets stuck at the step pisoFoam for 32 cores.

Basically, I changed the decompose method in the decomposeParDict to be scotch and increased the numberofSubdomains to be 32. Then, changed a few lines of Allrun in the lesfiles folder to use the RAS solution from 8 cores as the initial condition and then ran LES on 32 cores.
///////////////////////////////////////////////////////////////////////////////////
runApplication reconstructParMesh -constant -mergeTol 1e-6

runApplication reconstructPar

rm -rf processor*

# Set-up the LES case
rm -rf 0/
mv 500/ 0/
rm -rf 0/uniform/

cp system/decomposeParDict.scotch system/decomposeParDict

runApplication decomposePar

cp ../lesFiles/fvS* ../lesFiles/controlDict system/
cp ../lesFiles/LESProperties ../lesFiles/turbulenceProperties constant/
cp ../lesFiles/nuSgs 0/

#ls -d processor* | xargs -i rm -rf ./{}/0/uniform $1

ls -d processor* | xargs -i cp ../lesFiles/LESProperties ./{}/constant/ $1
ls -d processor* | xargs -i cp ../lesFiles/turbulenceProperties ./{}/constant/ $1
ls -d processor* | xargs -i cp ../lesFiles/nuSgs ./{}/0/ $1


runParallel pisoFoam 32

runApplication reconstructParMesh -constant -mergeTol 1e-6

runApplication reconstructPar
///////////////////////////////////////////////////////////////////////////////////
I don't know what is wrong here. Can anybody help me?

xiexiehezuo August 22, 2012 16:44

I figured out this problem. The reason is just the different run environment on the cluster. I changed the script. Now, it works fine.


All times are GMT -4. The time now is 14:07.