CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

can't start OF2.1 form remote computer

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 3, 2012, 11:14
Default can't start OF2.1 form remote computer
  #1
Member
 
Join Date: May 2010
Posts: 55
Rep Power: 7
hewei is on a distinguished road
HI All,

today I logged in the public server from my home. the user of the server station has been changed into another one. I tried many times but can not source the bashrc through my computer. so could anyone cal tell me what should I do to succeed in starting the OF far away in my home? ps the version of the OF is v2.1-x on Mac
Thank you!

W.
hewei is offline   Reply With Quote

Old   September 4, 2012, 04:15
Default
  #2
Senior Member
 
Bernhard
Join Date: Sep 2009
Location: Delft
Posts: 790
Rep Power: 12
Bernhard is on a distinguished road
It is a bit unclear what your problem is? What do you mean by 'can not source the bashrc'?
Bernhard is offline   Reply With Quote

Old   September 4, 2012, 05:38
Default
  #3
Member
 
Join Date: May 2010
Posts: 55
Rep Power: 7
hewei is on a distinguished road
Hi Bernhard,
Thanks for your reply.I mean, I cann't run Openfoam via "putty". you know I wanna send commands from my home to control the office computer.But now the computer which installed Openfoam logged into another user. it doesn't work. so I don't know how to do that without logging out others user.

Wei.

Quote:
Originally Posted by Bernhard View Post
It is a bit unclear what your problem is? What do you mean by 'can not source the bashrc'?
hewei is offline   Reply With Quote

Old   September 4, 2012, 05:39
Default
  #4
Senior Member
 
Bernhard
Join Date: Sep 2009
Location: Delft
Posts: 790
Rep Power: 12
Bernhard is on a distinguished road
Most machines can handle multiple users at the same time. What error message do you get?
Bernhard is offline   Reply With Quote

Old   September 4, 2012, 06:15
Default
  #5
Member
 
Join Date: May 2010
Posts: 55
Rep Power: 7
hewei is on a distinguished road
Quote:
Originally Posted by Bernhard View Post
Most machines can handle multiple users at the same time. What error message do you get?
and the "TAB" can't complete the commands automatically.
Attached Images
File Type: png folder.png (15.0 KB, 3 views)
File Type: png 2.png (7.3 KB, 3 views)
hewei is offline   Reply With Quote

Old   September 4, 2012, 06:35
Default
  #6
Senior Member
 
Bernhard
Join Date: Sep 2009
Location: Delft
Posts: 790
Rep Power: 12
Bernhard is on a distinguished road
Did you try icoFoam instead of icoFam?
Bernhard is offline   Reply With Quote

Old   September 4, 2012, 06:53
Default
  #7
Member
 
Join Date: May 2010
Posts: 55
Rep Power: 7
hewei is on a distinguished road
Quote:
Originally Posted by Bernhard View Post
Did you try icoFoam instead of icoFam?
Sorry I choose a wrong pic. you know ,if there is no something wrong in OF ,the "TAB" keyboard will be actived. ie. if I input "icoF" then press "TAB" it will display "icoFoam". But now all of the OF commands are not effective.
hewei is offline   Reply With Quote

Old   September 4, 2012, 15:47
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings to all!

@hewei: OF 2.1.x on Mac OS... I'm assuming you followed these instructions: http://openfoamwiki.net/index.php/Ho...enFOAM_v21_Mac

Since you're using another account, I'm only guessing that you should do once again the steps on following sections:
Best regards,
Bruno

Last edited by wyldckat; September 4, 2012 at 15:51. Reason: rephrased...
wyldckat is offline   Reply With Quote

Old   September 4, 2012, 17:08
Default
  #9
Member
 
Join Date: May 2010
Posts: 55
Rep Power: 7
hewei is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Greetings to all!

@hewei: OF 2.1.x on Mac OS... I'm assuming you followed these instructions: http://openfoamwiki.net/index.php/Ho...enFOAM_v21_Mac

Since you're using another account, I'm only guessing that you should do once again the steps on following sections:
Best regards,
Bruno
Thank you Bruno, this method I tried many times, but failed. I remembered if restart the computer and log into the account in which installing the OF, it need to click the OpenFOAM disk image firstly. then jump to step 2.4 and 2.5 as you said. But now is not allowed me to enter the OF disk image or change the account . I think I should first find a way to active the disk image,then maybe OF will work.

sincerely,
Wei
hewei is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
TimeVaryingMappedFixedValue irishdave OpenFOAM Running, Solving & CFD 28 May 28, 2015 13:37
Remote Desktop problem eshimshi FLUENT 2 November 24, 2010 17:22
Start star ccm+ remotely with mpiexec Dagnir CD-adapco 0 November 24, 2010 13:33
Please help cannot start lamboot hsieh OpenFOAM Installation 8 May 24, 2007 14:44
Lets start the public domain CFD-Project! Heinz Wilkening Main CFD Forum 3 March 11, 1999 23:55


All times are GMT -4. The time now is 02:37.