CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   Natural Convection channel flow using openfoam (http://www.cfd-online.com/Forums/openfoam-solving/108450-natural-convection-channel-flow-using-openfoam.html)

Rasesh October 24, 2012 06:29

Natural Convection channel flow using openfoam
 
I am using buoyantBoussinesqSimpleFoam of version 2.0.1.

I am trying to simulate 2D flow between 2 hot walls at 310 K.
my reference temperature is 300 K(which satisfies boussinisq approax.). i have given velocity zerogradient conditions, and p_rgh uniform 0 on both inlet and outlet. and no slip condition at the 2 walls.

I am getting good results when I do the simulation for cavity.

I have given initial velocity 0.3 which is the theoretical profile peak velocity. and temperature initially is 300 everywhere. I get my velocity profile decreasing as time marches and it approaches zero and it gains some random shape.(with velocities near wall getting negative than again positive maximum at the center and again negative near wall and zero at walls.)

the pressure and temperature profile are good enough.

the same thing happened with icoFoam with pressure boundary conditions, but decreasing time step solved it.

I have tried with 1e-60 :mad: time step. that also does not work, my CFL number is very much low with this timestep.

I have stuck on this from many days, tried many BCs, all giving same output. can anyone guide?
Thank you

AbdelkaderDZ July 4, 2013 10:13

Quote:

Originally Posted by Rasesh (Post 388262)
I am using buoyantBoussinesqSimpleFoam of version 2.0.1.

I am trying to simulate 2D flow between 2 hot walls at 310 K.
my reference temperature is 300 K(which satisfies boussinisq approax.). i have given velocity zerogradient conditions, and p_rgh uniform 0 on both inlet and outlet. and no slip condition at the 2 walls.

I am getting good results when I do the simulation for cavity.

I have given initial velocity 0.3 which is the theoretical profile peak velocity. and temperature initially is 300 everywhere. I get my velocity profile decreasing as time marches and it approaches zero and it gains some random shape.(with velocities near wall getting negative than again positive maximum at the center and again negative near wall and zero at walls.)

the pressure and temperature profile are good enough.

the same thing happened with icoFoam with pressure boundary conditions, but decreasing time step solved it.

I have tried with 1e-60 :mad: time step. that also does not work, my CFL number is very much low with this timestep.

I have stuck on this from many days, tried many BCs, all giving same output. can anyone guide?
Thank you

Dear Rasesh,
I have similar problem (natural convection in channel) I have a problem with BCs at the inlet and outler channel for p and p-rgh!
Any idea?
I need help,
Thanks


All times are GMT -4. The time now is 08:50.