CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

tracer transport using tri mesh?

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 13, 2012, 09:32
Default tracer transport using tri mesh?
  #1
Member
 
Join Date: Jul 2012
Posts: 31
Rep Power: 5
kpax is on a distinguished road
hello everyone,

as i posted in another thread, i am currently trying to simulate the flow in a branching vessel tree. In addition, i want to simulate the transport of a tracer in this domain by solving the convection-diffusion equation. for this purpose, i modified the icoFoam solver according to http://openfoamwiki.net/index.php/Ho...ure_to_icoFoam

i encountered some problems (i.e., unphysical results) when using a quad mesh that were probably due to the poor mesh quality. So i thought why not try a tri mesh - it is prone to numerical diffusion, i know, but it might give me a first idea of what happens in the domain.

So here's what's weird: first, the velocity field does not develop a parabolic profile as I would expect in a tubular region (see picture in attachment). but even stranger, the tracer is not transported along the domain at all! I can see an increase of concentration at the inlet (according to the BC there) - but that is it, the rest of the domain has c=0, as you can see in the attached picture.

I already tried different discretization schemes, but that did not yield any different results.


anyone has an idea whats going on here? maybe i missed something?



for the sake of completeness: i used deltaT = 0.0001 (different values did not affect result), the mesh has around a million cells (again, coarser meshes gave same results). the solver worked for different domains and hexa meshes, so i don't think it's the problem.
if more information is needed, i can post it.


thx in advance!
Attached Images
File Type: jpg velocity.jpg (16.1 KB, 10 views)
File Type: jpg tracer.jpg (13.7 KB, 9 views)
kpax is offline   Reply With Quote

Old   November 14, 2012, 12:05
Default
  #2
Senior Member
 
kmooney's Avatar
 
Kyle Mooney
Join Date: Jul 2009
Location: Amherst, MA USA - San Diego, CA USA
Posts: 285
Rep Power: 9
kmooney is on a distinguished road
Could post a quick picture of your mesh?
kmooney is offline   Reply With Quote

Old   November 16, 2012, 05:49
Default
  #3
Member
 
Join Date: Jul 2012
Posts: 31
Rep Power: 5
kpax is on a distinguished road
sure. mesh at the inlet looks something like this..
Attached Images
File Type: jpg mesh.jpg (97.3 KB, 4 views)
kpax is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Add Mesh Layers doesnt work on the whole surface Kryo OpenFOAM Native Meshers: snappyHexMesh and Others 8 September 13, 2012 09:28
snappyHexMesh won't work - zeros everywhere! sc298 OpenFOAM Native Meshers: snappyHexMesh and Others 2 March 27, 2011 21:11
external flow with snappyHexMesh chelvistero OpenFOAM 11 January 15, 2010 20:43
fluent add additional zones for the mesh file SSL FLUENT 2 January 26, 2008 12:55
Tri and Quad Mesh Sham FLUENT 1 December 3, 2007 03:55


All times are GMT -4. The time now is 07:41.