CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

bouyantBoussinesqPimpleFoam not working properly

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 18, 2012, 10:07
Default bouyantBoussinesqPimpleFoam not working properly
  #1
jki
New Member
 
Joaquim Monteiro
Join Date: Dec 2012
Posts: 12
Rep Power: 4
jki is on a distinguished road
Hello
I am making a simulated flow over a heat transfer cylinder.
I am using bouyantBoussinesqPimpleFoam but is not working properly.
After a certain time the number of Courant becomes very high and the simulation does not converge.
I've used the same geometry without heat transfer with pisoFoam and everything went well.

What am I doing wrong.

thank's
jki is offline   Reply With Quote

Old   December 18, 2012, 10:44
Default
  #2
Senior Member
 
adambarfi's Avatar
 
Mostafa Mahmoudi
Join Date: Jan 2012
Posts: 314
Rep Power: 6
adambarfi is on a distinguished road
Send a message via Yahoo to adambarfi Send a message via Skype™ to adambarfi
Quote:
Originally Posted by jki View Post
Hello
I am making a simulated flow over a heat transfer cylinder.
I am using bouyantBoussinesqPimpleFoam but is not working properly.
After a certain time the number of Courant becomes very high and the simulation does not converge.
I've used the same geometry without heat transfer with pisoFoam and everything went well.

What am I doing wrong.

thank's
dear Joaquim,
Welcome to Forum.

It may be caused by a lot of things, e.g.
- does it happen at the beging of your simulation? If yes your initial timestep might be too big...
- what Courant number do you set in controlDict?
- boundary conditions...

look at your log and see when the Courant number starts to rise. if you share your log, perhaps we can help you better.
adambarfi is offline   Reply With Quote

Old   December 19, 2012, 05:21
Default
  #3
jki
New Member
 
Joaquim Monteiro
Join Date: Dec 2012
Posts: 12
Rep Power: 4
jki is on a distinguished road
Thanks for the reply

I am using the same geometry for pisoFoam and the bouyantBoussinesqPimpleFoam.
All the surfaces placed at the same temperature, to see if the problem was to those files.

Initially the number of Courant's stable and then suddenly at 2 second begins to skyrocket and the problem not converge.


thank you
Attached Files
File Type: gz pimpleFoam.tar.gz (5.2 KB, 6 views)
jki is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
DEFINE_ADJUST not working properly akm Fluent UDF and Scheme Programming 0 April 18, 2011 10:09
Flapping wing rotation in Fluent 3D not working properly davesmith_01 FLUENT 1 February 13, 2011 22:35
Slip BC not working properly lfbarcelo OpenFOAM 3 July 15, 2010 09:53
Sample utility not working properly titio OpenFOAM 2 June 9, 2010 10:45
MultiComponenMixturecellMixture not working properly dominik_christ OpenFOAM Running, Solving & CFD 1 August 6, 2008 04:25


All times are GMT -4. The time now is 04:41.