CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

BC for outlet - interFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree3Likes
  • 2 Post By vainilreb
  • 1 Post By vainilreb

Reply
 
LinkBack Thread Tools Display Modes
Old   April 9, 2013, 09:34
Question BC for outlet - interFoam
  #1
Member
 
pedroxramos's Avatar
 
Pedro Ramos
Join Date: Mar 2012
Location: Portugal
Posts: 59
Rep Power: 5
pedroxramos is on a distinguished road
Hello!

I'm doing the flow simulation around a cylinder but this happens:

http://www.cfd-online.com/Forums/att...m-picture1.jpg

I'm thinking that the problem ins the boundary condition on "outlet".


What you suggest?

Best regards.
__________________
Pedro Ramos

FEUP, Portugal
pedroxramos is offline   Reply With Quote

Old   April 9, 2013, 09:40
Default
  #2
Member
 
Robert
Join Date: Aug 2012
Location: Berlin
Posts: 74
Rep Power: 5
vainilreb is on a distinguished road
1. What do we see on this picture? I guess it's alpha?
2. Where's the cylinder located?
3. Could you please post your BC files?

Thanks,

Robert
vainilreb is offline   Reply With Quote

Old   April 9, 2013, 09:49
Default
  #3
Member
 
pedroxramos's Avatar
 
Pedro Ramos
Join Date: Mar 2012
Location: Portugal
Posts: 59
Rep Power: 5
pedroxramos is on a distinguished road
Hi Robert!

See this video and you will understand:
https://dl.dropbox.com/u/22662045/8abril2.avi

Please, take a look on my files:
https://dl.dropbox.com/u/22662045/pier8abril2.rar
__________________
Pedro Ramos

FEUP, Portugal
pedroxramos is offline   Reply With Quote

Old   April 9, 2013, 10:46
Default
  #4
Member
 
Robert
Join Date: Aug 2012
Location: Berlin
Posts: 74
Rep Power: 5
vainilreb is on a distinguished road
Hi,

my first guess is that you should change your pressure BC. I'ts right to fix p_rgh to zero, but doing the same with p, which is p_rgh + rho*H*g won't work. I would give "phaseHydrostaticPressure" a try.

Best, Robert
vainilreb is offline   Reply With Quote

Old   April 9, 2013, 11:01
Default
  #5
Member
 
pedroxramos's Avatar
 
Pedro Ramos
Join Date: Mar 2012
Location: Portugal
Posts: 59
Rep Power: 5
pedroxramos is on a distinguished road
Thanks. I'm sorry but I'm new in openfoam, so i didn't understand clearly what you suggest.

"phaseHydrostaticPressure" is a BC?

should I change p for all patches or only in outlet?
__________________
Pedro Ramos

FEUP, Portugal
pedroxramos is offline   Reply With Quote

Old   April 9, 2013, 11:18
Default
  #6
Member
 
Robert
Join Date: Aug 2012
Location: Berlin
Posts: 74
Rep Power: 5
vainilreb is on a distinguished road
Oh, right. Sorry!
phaseHydrostaticPressure is a BC for pressure.
Try this for p --> outlet

type phaseHydrostaticPressure;
phaseName alpha1;
rho none;
pRefValue 0;
pRefPoint (0 0 0); // fill in z-coordinate of the water surface for z
value uniform 0;

I hope this helps. Please report.
Tobi and pedroxramos like this.
vainilreb is offline   Reply With Quote

Old   April 9, 2013, 12:14
Default
  #7
Member
 
pedroxramos's Avatar
 
Pedro Ramos
Join Date: Mar 2012
Location: Portugal
Posts: 59
Rep Power: 5
pedroxramos is on a distinguished road
thank you so much for your help. unfortunately, it dind't work. see for yourself: https://dl.dropbox.com/u/22662045/pier9april2.avi

the video is short but it seems that the problem is already there.

please, can you help me? i am with this problem for weeks....

thanks
__________________
Pedro Ramos

FEUP, Portugal
pedroxramos is offline   Reply With Quote

Old   April 9, 2013, 14:43
Default
  #8
Member
 
Robert
Join Date: Aug 2012
Location: Berlin
Posts: 74
Rep Power: 5
vainilreb is on a distinguished road
Hey,

I've had a closer look at your video and now I've realized that the graph in the lower right corner shows the plot of the values along the flow direction.
You see that the pressure is high at the inlet and drops to zero at the outlet, because you fixed it to zero.

Have you tried to set the BC for U at the outlet to "zeroGradient"?

I'll try some things tomorrow on my workstation, there's no OpenFOAM available here right now. But zeroGradient might already fix this.

Best regards,

Robert
pedroxramos likes this.
vainilreb is offline   Reply With Quote

Old   April 10, 2013, 06:03
Default
  #9
Member
 
pedroxramos's Avatar
 
Pedro Ramos
Join Date: Mar 2012
Location: Portugal
Posts: 59
Rep Power: 5
pedroxramos is on a distinguished road
It didn't work again :/ Video is here: https://dl.dropbox.com/u/22662045/pier9abril3.avi

And if the problem isn't in the outlet BC?

The files are here: https://dl.dropbox.com/u/22662045/pier9abril3.rar

I appreciate a little help!
__________________
Pedro Ramos

FEUP, Portugal
pedroxramos is offline   Reply With Quote

Old   April 16, 2013, 10:25
Default
  #10
Member
 
pedroxramos's Avatar
 
Pedro Ramos
Join Date: Mar 2012
Location: Portugal
Posts: 59
Rep Power: 5
pedroxramos is on a distinguished road
Hello again... it didn'w work... i'm working in this for weeks...it will turning me crazy!
__________________
Pedro Ramos

FEUP, Portugal
pedroxramos is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
InterFoam stops after deltaT goes to 1e14 francesco_b OpenFOAM Running, Solving & CFD 8 July 31, 2013 02:29
Perfect fluid implementation - interFoam Gaetano OpenFOAM Programming & Development 7 January 26, 2013 13:54
interFoam vs. simpleFoam channel flow comparison DanM OpenFOAM Running, Solving & CFD 11 January 5, 2013 07:21
Segmentation fault in interFoam run through openMPI voingiappone OpenFOAM 16 November 2, 2011 07:49
Open Channel Flow using InterFoam type solver sxhdhi OpenFOAM Running, Solving & CFD 3 May 5, 2009 21:58


All times are GMT -4. The time now is 16:40.