CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   3-D VAWT simulation using pimpleDyMFOAM not working (http://www.cfd-online.com/Forums/openfoam-solving/118533-3-d-vawt-simulation-using-pimpledymfoam-not-working.html)

Naruto May 29, 2013 10:00

3-D VAWT simulation using pimpleDyMFOAM not working
 
Dear FOAMers,
Hello everyone. I am currently trying to simulate flow around a VAWT using pimpleDyMFoam. But my solver is not working properly. It is crashing repeatedly. I have used different types of meshing and boundary conditions. But nothing seems to work. After a few time steps pimpleDyMFoam is crashing. Right now I am in a kind of frustrating situation.
Here are my case files: https://dl.dropboxusercontent.com/u/...ne/Turbine.rar

I would appreciate any kind of help.

waku2005 May 30, 2013 00:16

Dear Naruto

I also simulate straight Darius type VAWT using AMI.
I think you might have to be check your mesh quality using checkMesh command.
I suspect that meshes of high aspect ratio and high skewness would be found.

Sincerely
waku2005

Naruto May 30, 2013 05:49

Thank you for your kind and informative reply. I was a fool to post this thread. Yes you are absolutely right. Just after posting this thread, I checked my mesh using CheckMesh command and I found high skewness and non -orthogonality. I did not check this mesh before because I was quiet sure about the quality of the meshing. I would rebuild the mesh and than try simulation again. I will keep updating this thread.


All times are GMT -4. The time now is 09:38.