libsimpleFunctionObjects: functionObject name
I need to calculate massflow at certain patches for which I use libsimpleFunctionObjects.so.
However, when I specify the function object to be e.g.
the data will be saved in a folder named patchMassFlows__massflow. Is there a way to specify that patchMassFlows_ should not be included in the name?
It might seem to be a small problem but my postprocessing script relies on every functionObject to be saved under _<NAME>.
Short answer: No
Thank you for your reply.
I don't like to modify the source code unless absolutely necessary so I guess for now I will modify my postprocessing scripts slightly.
Is there any particular reason for adding the typename in front of the FO name as this doesn't seem to be standard OF behaviour (at least in 2.1)? Or have I misunderstood something here?
- Scripts. Mine say "Ah. 'patchMassFlow_*'. I know how to handle that"
- It is easier to remove files. "rm patch*" throws away all the patch-stuff. I don't have to look around "Err. 'fooFlow' is what? Ah. patchMassFlow. OK. Let it go"
So basically the types were added to the directory names because I think that redundant information makes life easier
|All times are GMT -4. The time now is 10:10.|