CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

OpenChannel with Two Cylinders in icoFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 7, 2013, 12:54
Default
  #21
Senior Member
 
Nima Samkhaniani
Join Date: Sep 2009
Location: Tehran, Iran
Posts: 1,189
Blog Entries: 1
Rep Power: 15
nimasam is on a distinguished road
Quote:
Originally Posted by jimbean View Post
Hi Nimasam,

Thanks for the suggestion.
Could you help me check this case?
I attached the link,
https://www.dropbox.com/s/5m2vw11e6a...ylinder.tar.gz
well, check your mesh, again, you assign a wrong patch as out-flow
Attached Images
File Type: png outflow-8.png (4.4 KB, 7 views)
__________________
Telegram channel (https://telegram.me/openfoam4Iranian)
My Weblog (http://openfoam.blogfa.com/)
Training Course on OpenFOAM at (http://www.isme.ir/)
nimasam is offline   Reply With Quote

Old   July 7, 2013, 13:02
Default
  #22
Senior Member
 
Nima Samkhaniani
Join Date: Sep 2009
Location: Tehran, Iran
Posts: 1,189
Blog Entries: 1
Rep Power: 15
nimasam is on a distinguished road
Quote:
Originally Posted by subhsngh View Post
i am posting my case
your mesh has wrong assigned patch, also severely non-orthogonal face, build new mesh
__________________
Telegram channel (https://telegram.me/openfoam4Iranian)
My Weblog (http://openfoam.blogfa.com/)
Training Course on OpenFOAM at (http://www.isme.ir/)
nimasam is offline   Reply With Quote

Old   July 7, 2013, 23:00
Default
  #23
New Member
 
Zhengbing
Join Date: Apr 2013
Posts: 20
Rep Power: 5
jimbean is on a distinguished road
How didi you find the wrong boundary.
I was using checkMesh, and it looks everything is ok.
Quote:
Originally Posted by nimasam View Post
well, check your mesh, again, you assign a wrong patch as out-flow
jimbean is offline   Reply With Quote

Old   July 8, 2013, 00:29
Default
  #24
Senior Member
 
Nima Samkhaniani
Join Date: Sep 2009
Location: Tehran, Iran
Posts: 1,189
Blog Entries: 1
Rep Power: 15
nimasam is on a distinguished road
your mesh configure is fine, as i said before, you assigned wrong patch as out-flow, you can see each patch by paraview, just click on patch name , and remove other patch name on paraview
__________________
Telegram channel (https://telegram.me/openfoam4Iranian)
My Weblog (http://openfoam.blogfa.com/)
Training Course on OpenFOAM at (http://www.isme.ir/)
nimasam is offline   Reply With Quote

Old   July 8, 2013, 08:05
Default
  #25
New Member
 
Zhengbing
Join Date: Apr 2013
Posts: 20
Rep Power: 5
jimbean is on a distinguished road
Hi Nimasam,

Thank you.
I changed the out-flow patch.
And now it can calculate, but some problems still exist, see figures below

There is no flow in the area (blue region) around the cylinders (represented by the gray circle). I have double checked the wall boundary, and it's right. So what's wrong with the blue region?

In the second figure, large velocity is found at the surface. Note different scale for these two figures. I gave a symmetryPlane boundary for the surface. Why did it cause big value at the surface?

If you want, find the case at
https://www.dropbox.com/s/vb3ge8jm4t...linders.tar.gz

Quote:
Originally Posted by nimasam View Post
your mesh configure is fine, as i said before, you assigned wrong patch as out-flow, you can see each patch by paraview, just click on patch name , and remove other patch name on paraview
Attached Images
File Type: jpg velocityField.jpg (28.8 KB, 7 views)
File Type: jpg velocityField-differentScale.jpg (28.5 KB, 4 views)
jimbean is offline   Reply With Quote

Old   July 9, 2013, 04:47
Default
  #26
Senior Member
 
Nima Samkhaniani
Join Date: Sep 2009
Location: Tehran, Iran
Posts: 1,189
Blog Entries: 1
Rep Power: 15
nimasam is on a distinguished road
i feel you need to increase cells number in z direction to atleast 4 cells, maybe it solves your problem
__________________
Telegram channel (https://telegram.me/openfoam4Iranian)
My Weblog (http://openfoam.blogfa.com/)
Training Course on OpenFOAM at (http://www.isme.ir/)
nimasam is offline   Reply With Quote

Old   July 9, 2013, 10:22
Default
  #27
New Member
 
Zhengbing
Join Date: Apr 2013
Posts: 20
Rep Power: 5
jimbean is on a distinguished road
Hi Nima

I increased the cells number in z direction to 8, but it didn't work.
Do you have any other ideas on this?
Thank you.

Quote:
Originally Posted by nimasam View Post
i feel you need to increase cells number in z direction to atleast 4 cells, maybe it solves your problem
jimbean is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2D Aerofoil with rotating cylinders - Help & Advice! Bluejay OpenFOAM 1 December 31, 2012 05:40
Density in icoFoam Densidad en icoFoam manuel OpenFOAM Running, Solving & CFD 8 September 22, 2010 04:10
[ICEM] generating tetra mesh on various cylinders at the same time karananand ANSYS Meshing & Geometry 2 July 9, 2010 16:34
Kubuntu uses dash breaks All scripts in tutorials platopus OpenFOAM Bugs 8 April 15, 2008 07:52
IcoFoam parallel woes msrinath80 OpenFOAM Running, Solving & CFD 9 July 22, 2007 02:58


All times are GMT -4. The time now is 22:49.