CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Problem with the use of PRISM elements in OF-2.1.1

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 30, 2013, 13:20
Default Problem with the use of PRISM elements in OF-2.1.1
  #1
Member
 
India
Join Date: Oct 2012
Posts: 84
Rep Power: 4
mayank.dce2k7 is on a distinguished road
Hi,

I am doing a simple steady state simulation(simpleFoam) in single bifurcating tube using tet+prism(near the solid walls) elements. At inlet, I have specified a fully developed velocity profile.

The problem is that fully developed velocity profile gets distorted in the straight section which should not happen(as I checked it by using pure tet mesh). The distortion occurs maximum where the transition from prism layer to tet layer occurs. How can I remove this distortion?

I have created the mesh in ICEM(in fluent format) and the total height of prism layers is about 5.2% of the radius of the straight section(parent tube). My mesh contains about 1.35 million elements(which is too much for such simple geometry.). It contains about 267,115 prism elements and approx 1.1 million tet elements.

Below are the snapshots of the geometry(half geometry), inlet velocity profile and velocity profile somewhere in straight section.
Attached Images
File Type: jpg Inlet Velocity Profile.jpg (25.7 KB, 5 views)
File Type: jpg gemoetry.jpg (11.3 KB, 9 views)
File Type: jpg Velocity profile in the middle of straight section.jpg (26.8 KB, 4 views)
mayank.dce2k7 is offline   Reply With Quote

Old   November 1, 2013, 02:16
Default
  #2
Member
 
India
Join Date: Oct 2012
Posts: 84
Rep Power: 4
mayank.dce2k7 is on a distinguished road
Any thoughts? Anybody?
mayank.dce2k7 is offline   Reply With Quote

Old   November 2, 2013, 07:08
Default
  #3
Member
 
cosimo bianchini
Join Date: Mar 2009
Location: Florence, Tuscany, Italy
Posts: 88
Rep Power: 8
cosimobianchini is on a distinguished road
Send a message via Skype™ to cosimobianchini
It is probably related to the last prism/first tetra height ratio. I think you have to redo your mesh increasing total prism layer height to or reducing tetra dimensions in the vicinity of the prism layer.
Regards,
Cosimo
__________________
Cosimo Bianchini

Energy Engineering Department "S. Stecco"
University of Florence
Via di S.Marta, 3
50139 Florence - ITALY
Tel: +39 055 4796575
Fax: +39 055 4796342
Mob: +39 320 9460153
e-mail: cosimo.bianchini@htc.de.unifi.it
URL: www.htc.de.unifi.it
cosimobianchini is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with skewed elements s7evin FLUENT 14 January 28, 2012 10:38
problem in prism layer generation shrimp CFX 5 March 26, 2010 13:34
Penetrating elements in extruded mesh Michael P CFX 2 May 20, 2005 08:06
Prism Elements ashish CFX 0 April 20, 2005 06:03
CFX4.3 -build analysis form Chie Min CFX 5 July 12, 2001 23:19


All times are GMT -4. The time now is 05:54.