CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   Wrong results in OpenFoam parallel runs (http://www.cfd-online.com/Forums/openfoam-solving/126122-wrong-results-openfoam-parallel-runs.html)

visakhmg November 8, 2013 08:39

Wrong results in OpenFoam parallel runs
 
Hello everyone,
I am runing 3D incompressible cases with simpleFoam as well as porousSimpleFoam in OpenFoam 2.1.1. I have noticed that when i start a parallel run from scratch (from time 0), it gives me wrong results and some times the simulation blows off. But when I start the parallel run after a few (say 50) time steps in seriala and switch on to parallel, it gives me reasonable reults. I am using scotch decomposition method and the domain is relatively bulky. Does the error increase with number of processors I am using? I heard there is some problem with parallelization in OpenFoam 2.1.1. Is it true? And finally, what is the diference between scotch and metis decomposition methods?

wyldckat November 9, 2013 14:13

Greetings Visakh,

It doesn't matter as much the version of OpenFOAM you are using, because any version can lead to a crash, if certain details are not taken into account when running in parallel, as listed here: http://www.cfd-online.com/Forums/ope...tml#post324934 - post #28 provides a list of known reasons why a run might not go well in parallel.

Best regards,
Bruno


All times are GMT -4. The time now is 03:22.