CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   A problem about parallel computing (http://www.cfd-online.com/Forums/openfoam-solving/126488-problem-about-parallel-computing.html)

babala November 19, 2013 05:33

A problem about parallel computing
 
Hello,
I am running a test on a Redhat server.I plan to run the test with two nodes(every node has 8 CPUs). We can name the two nodes as node1 and node2.
I use the commond as userguide:

mpirun -hostfile machine -np 16 rhoCentralFoam -parallel

The file of machine is like this:
node1
node2

However, the terminal gives me a error information follows:

--------------------------------------------------------------------------
Open RTE detected a parse error in the hostfile:
machine
It occured on line number 3 on token 1.
--------------------------------------------------------------------------
[c2-8:27938] [[27546,0],0] ORTE_ERROR_LOG: Error in file base/ras_base_allocate.c at line 222
[c2-8:27938] [[27546,0],0] ORTE_ERROR_LOG: Error in file base/plm_base_launch_support.c at line 99
[c2-8:27938] [[27546,0],0] ORTE_ERROR_LOG: Error in file plm_rsh_module.c at line 1173

Then, I just use one node, And I modify the file of machine as this:

node1

And input the commond
mpirun -hostfile machine -np 8 rhoCentralFoam -parallel

the solver can work successifully.
And the other node is OK,too.I don't know how to solve this problem.

Any answers is appreciated.

best regards
Zhiyuan Li

wyldckat November 26, 2013 18:23

Greetings Zhiyuan Li and welcome to the forum!

Quick answer - follow these instructions: 7. How do I run a simple SPMD MPI job?

Long answer - check this blog post with a lot of links that can help with several topics regarding running in parallel: Notes about running OpenFOAM in parallel

Best regards,
Bruno

babala November 27, 2013 00:31

Quote:

Originally Posted by wyldckat (Post 463646)
Greetings Zhiyuan Li and welcome to the forum!

Quick answer - follow these instructions: 7. How do I run a simple SPMD MPI job?

Long answer - check this blog post with a lot of links that can help with several topics regarding running in parallel: Notes about running OpenFOAM in parallel

Best regards,
Bruno


hello, Bruno.
Thank you for your replies.
I have solved the problems. I created the file of machine.txt in Windows system and editted it in Windows system,too.And, Linux system can't identify contents of the file.Then I editted the file by vim and the solver can run in parallel perfectly.
The mistake is so stupid.Hope somebody else won't make the same mistake.

Best regards
Zhiyuan


All times are GMT -4. The time now is 01:00.