CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

error when running sample "size 30 is not equal to the given value of 40"

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 20, 2013, 14:13
Default error when running sample "size 30 is not equal to the given value of 40"
  #1
Senior Member
 
ArathoN
Join Date: Jul 2011
Posts: 137
Rep Power: 8
ArathoN is on a distinguished road
Whenever i try to run the sample function i have this error:

Code:
--> FOAM FATAL IO ERROR: 
size 30 is not equal to the given value of 40

file: /home/arathon/Tesi/Cases/K-E/BackwardFacingStep-15/0/wallShearStress.boundaryField.inlet from line 26 to line 27.

    From function Field<Type>::Field(const word& keyword, const dictionary&, const label)
    in file /home/opencfd/OpenFOAM/OpenFOAM-2.2.2/src/OpenFOAM/lnInclude/Field.C at line 236.

FOAM exiting
this appeared after i used the mesh from gambit, but the mesh built properly without error idem for the solver. I have all the value of the wallshearstress in the time directories.

The sample code:
Code:
/*--------------------------------*- C++ -*----------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  2.2.2                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.org                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
FoamFile
{
    version     2.0;
    format      ascii;
    class       dictionary;
    object      sampleDict;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //


setFormat gnuplot;

surfaceFormat raw;

interpolationScheme cellPoint;
fields
(
    "wallShearStress"
);

sets
(
    
lineX1
    {
        type        face;
        axis        x;

        start       (0 -0.1 0);
        end         (2.5 -0.1 0);
        nPoints     400;
    }

);

surfaces
(
    
 walls_interpolated
    {
        type            patch;
        patches         ( "lowerWall" );
        interpolate     true;
    }

);
ArathoN is offline   Reply With Quote

Old   February 20, 2014, 16:02
Default
  #2
Senior Member
 
ArathoN
Join Date: Jul 2011
Posts: 137
Rep Power: 8
ArathoN is on a distinguished road
This was a stupid mistake i calculated the wallshearstress then i modified the mesh without deleting the wallshearstress' file in the /0 directory so when i decomposed he didn't like the change.
ArathoN is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
erros when running sample command hewei OpenFOAM Post-Processing 3 April 15, 2012 04:50
Sample issues MikePo OpenFOAM Post-Processing 1 February 7, 2010 20:20
Statically Compiling OpenFOAM Issues herzfeldd OpenFOAM Installation 21 January 6, 2009 10:38
Kubuntu uses dash breaks All scripts in tutorials platopus OpenFOAM Bugs 8 April 15, 2008 07:52


All times are GMT -4. The time now is 19:14.