CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Error with 8cpu

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 9, 2014, 05:20
Default Error with 8cpu
  #1
New Member
 
Join Date: Mar 2014
Posts: 23
Rep Power: 3
michael157 is on a distinguished road
Hello,

i have a problem in OpenFOAM running in parallel.
I have post processed a case and doing a run with 4 cpu´s and everything is working fine.
When I do a change in the decomposeParDict from 4 to 8 cpus i got the attached error message:

/*---------------------------------------------------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 2.3.0 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
Build : 2.3.0-f5222ca19ce6
Exec : chtMultiRegionFoam -parallel
Date : Jul 09 2014
Time : 11:12:10
Host : "chshws20050t"
PID : 9244
Case : /home/dettling_m/OpenFOAM/dettling_m-2.3.0/run/SIM01_1m-s_to_10m-s/StepPlate_St1-0_2m-s_150s_8cpu
nProcs : 8
Slaves :
7
(
"chshws20050t.9245"
"chshws20050t.9246"
"chshws20050t.9247"
"chshws20050t.9248"
"chshws20050t.9249"
"chshws20050t.9250"
"chshws20050t.9251"
)
Pstream initialized with:
floatTransfer : 0
nProcsSimpleSum : 0
commsType : nonBlocking
polling iterations : 0
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster
allowSystemOperations : Disallowing user-supplied system call operations
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time
Create fluid mesh for region bottomWater for time = 0
[5]
[5]
[5] --> FOAM FATAL ERROR:
[5] Cannot find file "points" in directory "bottomWater/polyMesh" in times 0 down to constant
[5]
[5] From function Time::findInstance(const fileName&, const word&, const IOobject::readOption, const word&)
[5] in file db/Time/findInstance.C at line 203.
[5]
FOAM parallel run exiting
...

what am I doing wrong?
In the following, my decomposeParDict file:
/*--------------------------------*- C++ -*----------------------------------*\
| ========= | |
| \\ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \\ / O peration | Version: 2.3.0 |
| \\ / A nd | Web: www.OpenFOAM.org |
| \\/ M anipulation | |
\*---------------------------------------------------------------------------*/
FoamFile
{
version 2.0;
format ascii;
class dictionary;
note "mesh decomposition control dictionary";
location "system";
object decomposeParDict;
}
// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
numberOfSubdomains 8;
//- Keep owner and neighbour on same processor for faces in zones:
// preserveFaceZones (heater solid1 solid3);
// method scotch;
method hierarchical;
// method simple;
// method manual;
simpleCoeffs
{
n (2 2 1);
delta 0.001;
}
hierarchicalCoeffs
{
n (2 2 2);
delta 0.001;
order xyz;
}

manualCoeffs
{
dataFile "decompositionData";
}


Thank you very much for your help!
michael157 is offline   Reply With Quote

Old   July 10, 2014, 09:33
Default
  #2
Senior Member
 
Bernhard
Join Date: Sep 2009
Location: Delft
Posts: 790
Rep Power: 12
Bernhard is on a distinguished road
Did you again decompose your case? How many processor-directories do you got?
Bernhard is offline   Reply With Quote

Old   July 10, 2014, 10:11
Default
  #3
Member
 
Derek Mitchell
Join Date: Mar 2014
Location: UK, Reading
Posts: 95
Rep Power: 4
derekm is on a distinguished road
I see this error a lot of times in my multiregion stuff.
I get this if I havent modded the numberOfSubdomains to agree in decomposeParDict in ALL regions as well as at the top.
__________________
A CHEERING BAND OF FRIENDLY ELVES CARRY THE CONQUERING ADVENTURER OFF INTO THE SUNSET
derekm is offline   Reply With Quote

Old   July 11, 2014, 02:03
Default
  #4
New Member
 
Join Date: Mar 2014
Posts: 23
Rep Power: 3
michael157 is on a distinguished road
I get only 4 directories for the processors

processor 0
...
processor 3

What is the problem?
I set the decomposeParDict to 8 cpus
and I am doing the MPI with 8
michael157 is offline   Reply With Quote

Old   July 11, 2014, 02:06
Default
  #5
New Member
 
Join Date: Mar 2014
Posts: 23
Rep Power: 3
michael157 is on a distinguished road
I set the number of subdomains to 8 see the file

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
numberOfSubdomains 8;

method hierarchical;

hierarchicalCoeffs
{
n (2 2 2);
delta 0.001;
order xyz;
}

manualCoeffs
{
dataFile "decompositionData";
}

I have absolute no idea what the error is because when I am doing the some thing only with 4 CPU it works fine
michael157 is offline   Reply With Quote

Old   July 11, 2014, 08:17
Default
  #6
New Member
 
Siddharth Selva
Join Date: Jul 2014
Posts: 3
Rep Power: 2
sidselva is on a distinguished road
try setting it (2 4 1) or (8 1 1) on the simpleCoeffs.
With your original (2 2 1) you are only splitting it into four pieces.
sidselva is offline   Reply With Quote

Old   July 14, 2014, 02:22
Default
  #7
New Member
 
Join Date: Mar 2014
Posts: 23
Rep Power: 3
michael157 is on a distinguished road
I tried the configuration with (8 1 1), with (2 4 1) and got the error again.
I tried to do it with 2 CPU (2 1 1) and i got an error as well. When i had a look into the folder, i see 4 folders for processors (processor 0, ..., processor 3)

I do not understand whats going on. Why is it working with 4 CPU and not with 2 or 6 or 8?
michael157 is offline   Reply With Quote

Old   July 14, 2014, 03:13
Default
  #8
Senior Member
 
Lieven
Join Date: Dec 2011
Location: Mol, Belgium
Posts: 295
Rep Power: 13
Lieven will become famous soon enough
Can you post the output of 'decomposePar' in case of (8 1 1) or (4 2 1)?
Lieven is offline   Reply With Quote

Old   July 14, 2014, 06:45
Default
  #9
New Member
 
Join Date: Mar 2014
Posts: 23
Rep Power: 3
michael157 is on a distinguished road
I have solved the problem.
I am running a case with multi region and in the region folder there is another file for decomposing. Here was always the entry 4 for CPUs. I have changed this for each region from 4 to 8 and now it is running correctly.

Thanks a lot for your help!
michael157 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:04.