CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Beowulf cluster open foam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 18, 2014, 10:54
Angry Beowulf cluster open foam
  #1
nfo
New Member
 
Nfo
Join Date: Aug 2014
Posts: 2
Rep Power: 0
nfo is on a distinguished road
I am creating a cluster with ubuntu 12.04 tls and I have done all the steps in the manual I found on this forum. The problem I have is that when doing the test that appears in the manual, the executable does not work, and which is not the problem. I get this error:

ru @ master: ~ $ mpirun np 4 --hostfile machines --rankfile rankfile interFoam -Parallel> log &
[1] 4575
ru @ master: ~ $ -------------------------------------------- ------------------------------
mpirun was unable to launch the specified application as it Could not find an executable:

Executable: interFoam
Node: nodo01

while attempting to start process rank 2.
-------------------------------------------------- ------------------------

no longer continue, not if the problem is in the cluster, the command .... someone help me ???

The version of openfoam I am using is 2.3.0

Thank you for help!
nfo is offline   Reply With Quote

Old   September 1, 2014, 00:51
Default
  #2
New Member
 
liyu
Join Date: Jan 2014
Location: Beijing
Posts: 10
Rep Power: 3
ahliyu is on a distinguished road
you can try this command:

mpirun –hostfile machines –np 12 /home/inet107/OpenFoam/OpenFoam-2.3.0/bin/foamExec ico22968 -parallel
ahliyu is offline   Reply With Quote

Old   September 1, 2014, 03:47
Default
  #3
nfo
New Member
 
Nfo
Join Date: Aug 2014
Posts: 2
Rep Power: 0
nfo is on a distinguished road
thanx for help.

and I resolved the problem, I was in the bashrc file, and I had to put the path / opt / openfoam230 / ect / bashrc in the first line of the file. Before you put it at the end and did not work me.


Thank you
nfo is offline   Reply With Quote

Reply

Tags
openfoam cluster beowulf

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM without MPI kokizzu OpenFOAM Installation 4 May 26, 2014 09:17
Swak4Foam funkyDoCalc with OF2.3 massflow NiFl OpenFOAM 8 March 24, 2014 21:06
Errors during blockMesh meshing Madeleine P. Vincent OpenFOAM Native Meshers: blockMesh 43 February 18, 2014 03:42
non-orthogonal faces and incorrect orientation? nennbs OpenFOAM Native Meshers: blockMesh 7 April 17, 2013 05:42
Running Foam on multiple nodes (small cluster) Hisham OpenFOAM Running, Solving & CFD 4 June 11, 2012 13:44


All times are GMT -4. The time now is 14:26.