CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

no output in elasticIncrSolidFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 14, 2014, 07:40
Default no output in elasticIncrSolidFoam
  #1
New Member
 
Peter Knapen
Join Date: Sep 2009
Posts: 25
Rep Power: 7
peterk is on a distinguished road
Hi All,
I am trying to model a droptest in openFoamextend 3.1 solidMechanics. As I am new to openFoam, I first trie to drop a tank (2D) on a floor. I have modeled the tank and floor in Hypermesh and exported the mesh to openFoam. Next I have renamed the name of the walls in the elasticIncrSolidFoam to the names I have used in Hypermesh and commented out the blockMesh line in Allrun.
In a later stage the fluid has to be added.
As I do not now how to prescribe the initial velocity to the tank, I have prescribed a large displacement in time of the upper outer faces of the tank.
The analysis does run and I get results for the contact forces, but the results are not written to the various output directories. Only directory 0 exists.

I have attached some of the listing of this problem, any idea what I have to do to get output?
Best regards,
Peter
Attached Files
File Type: gz droptest.tar.gz (89.5 KB, 2 views)
peterk is offline   Reply With Quote

Old   October 15, 2014, 05:05
Default
  #2
New Member
 
Peter Knapen
Join Date: Sep 2009
Posts: 25
Rep Power: 7
peterk is on a distinguished road
I found the source of my problem, the output frequency in the controlDict was too high.

How should I impose an initial velocity to the tank nodes (primary variable is displacement not velocity)?
Peter
peterk is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
outputTime in Swak function immortality OpenFOAM Post-Processing 8 June 28, 2015 16:25
writing execFlowFunctionObjects immortality OpenFOAM Post-Processing 30 September 15, 2013 06:16
RNG diverged during the analysis the flow over a multi element airfoil, why? s.m OpenFOAM Running, Solving & CFD 0 August 5, 2013 08:39
mixerVesselAMI2D's mass is not balancing sharonyue OpenFOAM Running, Solving & CFD 6 June 10, 2013 09:34
lift and drag on ship superstructures vaina74 OpenFOAM Running, Solving & CFD 3 June 8, 2010 12:30


All times are GMT -4. The time now is 16:52.