CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

own turbulence model not working in parallel

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 1 Post By wyldckat
  • 1 Post By wyldckat

Reply
 
LinkBack Thread Tools Display Modes
Old   June 10, 2015, 15:27
Default own turbulence model not working in parallel
  #1
dsn
Member
 
Aditya
Join Date: Nov 2014
Posts: 35
Rep Power: 4
dsn is on a distinguished road
Hi everyone,

I have modified and implemented a new turbulence model in openfoam and compiled the library succesfully. I have also used the turbulence model without any problem on a single processor. But when i try to decompose the domain and run it in parallel, I get the follwing error

HTML Code:
Processor 1
    Number of cells = 6473
    Number of faces shared with processor 0 = 100
    Number of faces shared with processor 3 = 67
    Number of processor patches = 2
    Number of processor faces = 167
    Number of boundary faces = 13109
--> FOAM Warning : 
    From function dlOpen(const fileName&, const bool)
    in file POSIX.C at line 1179
    dlopen error : /home/aditya/OpenFOAM/aditya-2.3.0/platforms/linux64GccDPOpt/lib/libmyIncompressibleRASTransitionModel.so: undefined symbol: _ZTIN4Foam14incompressible8RASModelE
--> FOAM Warning : 
    From function dlLibraryTable::open(const fileName&, const bool)
    in file db/dynamicLibrary/dlLibraryTable/dlLibraryTable.C at line 99
    could not load "libmyIncompressibleRASTransitionModel.so"
The name of the library is ""libmyIncompressibleRASTransitionModel.so". Is there anything extra that needs to be done when you implement your own model to make it run in parallel. It would be great if someone can help me out with this.

Thanks in advance!!
dsn is offline   Reply With Quote

Old   June 11, 2015, 05:42
Default
  #2
Member
 
Yogesh Bapat
Join Date: Oct 2010
Posts: 43
Rep Power: 8
ybapat is on a distinguished road
Hello,
Add line
libs ("libmyIncompressibleRASTransitionModel.so");
to controlDict file so that decomposepar is able to load your library.

Regards,
-Yogesh
ybapat is offline   Reply With Quote

Old   June 11, 2015, 14:01
Default
  #3
New Member
 
Aditya D S N
Join Date: Oct 2011
Posts: 5
Rep Power: 7
adityadsn is on a distinguished road
Hi,

I do have that line in my control dict. It works perfectly when i run the case in serial but when i try to run it in parallel it gives me the error. when i use the decomposePar command, i get the above mentioned error.
adityadsn is offline   Reply With Quote

Old   June 17, 2015, 15:34
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,736
Blog Entries: 39
Rep Power: 103
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
Quick answer: Change the line:
Code:
libs   ("libmyIncompressibleRASTransitionModel.so");
To possibly this:
Code:
libs   (
"libmyIncompressibleRASTransitionModel.so"
"libincompressibleRASModels.so"
);
Because of this error:
Code:
undefined symbol: _ZTIN4Foam14incompressible8RASModelE
This error doesn't happen with the solver, because the solver already is linked to this library for the RAS models.
dsn likes this.
wyldckat is offline   Reply With Quote

Old   June 17, 2015, 16:52
Default
  #5
dsn
Member
 
Aditya
Join Date: Nov 2014
Posts: 35
Rep Power: 4
dsn is on a distinguished road
Thank you so much wyldkat. That worked!!

But I'm a little curious because this worked

HTML Code:
libs ("libincompressibleRASModels.so" "libmyIncompressibleRASTransitionModel.so" "libfindroot.so"  );
but this did not. It gave me an error.

HTML Code:
libs ( "libmyIncompressibleRASTransitionModel.so" "libfindroot.so" "libincompressibleRASModels.so" );
Can you tell me why this happens and why do we need to link the libincompressibleRAS.so in the first place while running user defined turbulence models.

Regards,
Aditya
dsn is offline   Reply With Quote

Old   June 21, 2015, 15:58
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,736
Blog Entries: 39
Rep Power: 103
wyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of lightwyldckat is a glorious beacon of light
Quote:
Originally Posted by dsn View Post
Can you tell me why this happens and why do we need to link the libincompressibleRAS.so in the first place while running user defined turbulence models.
Quick answer: I thought it was pretty obvious that your library "libmyIncompressibleRASTransitionModel.so" depends on this symbol:
Code:
undefined symbol: _ZTIN4Foam14incompressible8RASModelE
And this symbol is defined in the library "libincompressibleRASModels.so".
Unfortunately I was in a hurry and didn't think about the loading priority, namely that we must first load the library that has the symbol we need, so that we can load our own library.
potentialFoam likes this.
wyldckat is offline   Reply With Quote

Old   January 12, 2016, 20:12
Default Error message after runing paraFoam
  #7
New Member
 
adhi makayasa
Join Date: Apr 2015
Posts: 20
Rep Power: 3
makayasa is on a distinguished road
Hi all,
after running paraFoam, in the terminal to get a message like this.

From function dlOpen(const fileName&, const bool)
in file POSIX.C at line 1179
dlopen error : /home/yasa/OpenFOAM/yasa-2.3.0/platforms/linuxGccDPOpt/lib/libmyIncompressibleRASModels.so: undefined symbol: _ZTIN4Foam14incompressible8RASModelE

FOAM Warning :
From function dlLibraryTable:pen(const fileName&, const bool)
in file db/dynamicLibrary/dlLibraryTable/dlLibraryTable.C at line 99
could not load "libmyIncompressibleRASModels.so"

How to fix it? Please help, this is my final assignment
makayasa is offline   Reply With Quote

Old   February 24, 2016, 22:46
Default
  #8
New Member
 
Sami
Join Date: Dec 2014
Posts: 1
Rep Power: 0
Newuser10 is on a distinguished road
Hello guys,

I got same message but after I run the solver "pisoFoam" .... the message was:

pisoFoam: symbol lookup error: /.../..../OpenFOAM/......-2.1.0/platforms/linux64GccDPOpt/lib/libincompressibleRASModels.so: undefined symbol: _ZTIN4Foam14incompressible8RASModelE

I do not know how to solve!!!!!! any idea ??

Thanks a lot ..
Sami
Newuser10 is offline   Reply With Quote

Old   February 29, 2016, 12:08
Default
  #9
Member
 
Peter
Join Date: Nov 2015
Location: Hamburg, Germany
Posts: 37
Rep Power: 3
potentialFoam is on a distinguished road
Dear Sami,

seems as if the same library is not linked.
Can you please post your controlDict-file?

Peter
potentialFoam is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parallel running of 3D multiphase turbulence model (unknown problem!!) MOHAMMAD67 OpenFOAM Running, Solving & CFD 7 November 23, 2015 11:53
Turbulence Model - Linking Issues? AA29 OpenFOAM Programming & Development 3 June 20, 2014 15:21
Compressible turbulence model issues 351Cleveland OpenFOAM 5 October 24, 2013 15:41
new turbulence model in Fluent C.C FLUENT 0 August 29, 2013 10:44
Sinclair Model + secondary turbulence Yi FLUENT 0 October 26, 2001 13:37


All times are GMT -4. The time now is 17:23.