CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Mesh Problem with icoDyMFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 12, 2009, 18:57
Default Hallo everybody, Hoping you
  #1
Member
 
Hai Yu
Join Date: Mar 2009
Location: OvgU, Magdeburg
Posts: 65
Rep Power: 8
yuhai is on a distinguished road
Hallo everybody,
Hoping you have had a good new years day, but I am facing a new problem. (^0^)
I made a geography and mesh by Gambit (2D), as shown below. The structure is based on my own understanding of the requirement of icoDyMFoam, I am still not sure about whether it is right or wrong.
I devided the region inside to two parts, one around a two-blade turbo, it contains the moving cells; and one on outside, it contains the stative cells. For the project, air flow from left to right, and the turbo rotates.

I converted the mesh to Foam format, and edited it, then run icoDyMFoam, then the error message shows:

Create dynamic mesh for time = 0
Selecting dynamicFvMesh mixerFvMesh
--> FOAM FATAL ERROR : Error in face ordering: mixed used and unused faces at the end of face list.
Number of used faces: 5219 and face 5219 is owned by cell 0
From function void polyMesh::initMesh()
in file meshes/polyMesh/polyMeshCalcFaceCells.C at line 107.
FOAM aborting

(In the mesh, totally 12031 faces, 6812 are for frontAndBackPlanes, 5219 are for faces used to seperate cells.)

Has anybody any idea on how this is about?

And I have still another question: in the example of mixer2D, file "cellZones" contains only movingCells. So, how will Foam find out the stative cells and deal with them?

Thx in advance.
yuhai is offline   Reply With Quote

Old   January 12, 2009, 18:59
Default can anybody tell me how to upl
  #2
Member
 
Hai Yu
Join Date: Mar 2009
Location: OvgU, Magdeburg
Posts: 65
Rep Power: 8
yuhai is on a distinguished road
can anybody tell me how to upload a picture?
yuhai is offline   Reply With Quote

Old   January 13, 2009, 05:40
Default according to the website : ht
  #3
Member
 
florian
Join Date: Mar 2009
Location: Mannheim - Vincennes - Valenciennes, Deutchland - France
Posts: 34
Rep Power: 8
floooo is on a distinguished road
according to the website :
http://www.cfd-online.com/cgi-bin/Op...?pg=formatting

\image{Text description}

if it doesn't work you can upload the picture on a website like this one :
http://www.imagup.com/index.php?page=upload
and then put the link
floooo is offline   Reply With Quote

Old   January 13, 2009, 12:42
Default This is a picture of me: http:
  #4
Member
 
Hai Yu
Join Date: Mar 2009
Location: OvgU, Magdeburg
Posts: 65
Rep Power: 8
yuhai is on a distinguished road
This is a picture of me:
yuhai is offline   Reply With Quote

Old   January 13, 2009, 18:45
Default Really? That is you? (I apo
  #5
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Really? That is you?

(I apologize for the cheap joke)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   January 14, 2009, 15:57
Default hallo, Bernhard, and all, tha
  #6
Member
 
Hai Yu
Join Date: Mar 2009
Location: OvgU, Magdeburg
Posts: 65
Rep Power: 8
yuhai is on a distinguished road
hallo, Bernhard, and all,
thanks, florian

I made some modifications, and now the problem changed to:

____________________________________
--> FOAM FATAL ERROR : Zero length edge detected. Probable projection error: slave patch probably does not project onto master. Please switch on enriched patch debug for more info

From function void enrichedPatch::calcCutFaces() const
in file slidingInterface/enrichedPatch/enrichedPatchCutFaces.C at line 248.
______________________

can anybody give some hints about this?
yuhai is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mesh Problem with icoDyMFoam yuhai OpenFOAM Running, Solving & CFD 0 January 12, 2009 18:53
Problem with icoDyMFoam olivier OpenFOAM Running, Solving & CFD 13 December 19, 2008 10:03
Problem with icoDyMFoam tutorial matlie OpenFOAM Bugs 10 April 26, 2007 04:51
Problem starting with icoDyMFoam kassiotis OpenFOAM Running, Solving & CFD 1 March 12, 2007 12:12
Problem with icoDyMFoam philippose OpenFOAM Running, Solving & CFD 19 March 7, 2007 13:06


All times are GMT -4. The time now is 22:53.