CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Running, Solving & CFD (
-   -   InterDyMFoam and problem with setFields (

chris_sev January 8, 2009 10:03

hi everybody!! I m going th
hi everybody!!

I m going through tutorial cases which come with OF 1.5
All sloshingTank examples seem to work fine. After first 'investigations' of these stuff I wanted to change geometry a bit so I modified blockMesh and then I met problems. All I did at the beginning was making mesh finer. Then I used setFields tool to change initial values of gamma. Unfortunately after re-used of setFields solver doesn't run.

here you can see part of log file:
-------------------------------------------------------------------------------- --------------------------------
Create time

Create mesh for time = 0

Selecting dynamicFvMesh solidBodyMotionFvMesh
Selecting solid-body motion function SDA

Reading environmentalProperties
Reading field pd

Reading field gamma

Reading field U

Reading/calculating face flux field phi

Reading transportProperties

Selecting incompressible transport model Newtonian
Selecting incompressible transport model Newtonian
Selecting RAS turbulence model laminar
time step continuity errors : sum local = 0, global = 0, cumulative = 0
GAMGPCG: Solving for pcorr, Initial residual = 0, Final residual = 0, No Iterations 0
[0] #0 Foam::error::printStack(Foam:
-------------------------------------------------------------------------------- --------------------------------

I have noticed that this happens only when setFields tool is reused.

Do you have any idea what's the problem?

any help would be appreciated!!!


musahossein March 23, 2009 22:23

Some times OpenFoam will create a back up file which may be re-read instead of the intended file. I would suggest that before each run, go to the folder where set fielddict is and delete the backup file. Then run setFields. It should work.

All times are GMT -4. The time now is 21:08.