CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

The setParabolicInlet problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 22, 2008, 21:59
Default hi, when i use "setParabolic
  #1
Senior Member
 
weihong yao
Join Date: Mar 2009
Posts: 117
Rep Power: 8
ivanyao is on a distinguished road
hi,
when i use "setParabolicInlet" application,it show:
setParabolicInlet /home/user/skolan/OpenFOAM/skolan-1.3/run/tutorials/sonicFoam backwardStep inlet 0.01 -z_noncenter -parallel -y_noncenter
-----------------------------------------------------------------------------

It seems that there is no lamd running on the host newton.

This indicates that the LAM/MPI runtime environment is not operating.
The LAM/MPI runtime environment is necessary for MPI programs to run
(the MPI program tired to invoke the "MPI_Init" function).

Please run the "lamboot" command the start the LAM/MPI runtime
environment. See the LAM/MPI documentation for how to invoke
"lamboot" across multiple machines.
-------------------------------------------------
how to fix it?thank you!
ps:I use OF1.4 IN SUSE10.2.
ivanyao is offline   Reply With Quote

Old   September 23, 2008, 06:57
Default If you're using the setParabol
  #2
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,914
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
If you're using the setParabolicInlet that floats around here, be advised that it doesn't work correctly on parallel cases (at least the version I wrote). Therefore the -parallel option should not be used (and it only makes sense if you've got an mpirun, or similar, before the call to the solver.

Bernhard
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 24, 2008, 02:20
Default hi. thank you for your answer
  #3
Senior Member
 
weihong yao
Join Date: Mar 2009
Posts: 117
Rep Power: 8
ivanyao is on a distinguished road
hi.
thank you for your answer.but now i do not know what can i do?
ivanyao is offline   Reply With Quote

Old   September 24, 2008, 05:48
Default Try running it without -parall
  #4
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,914
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Try running it without -parallel
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 24, 2008, 21:50
Default hi, thank you!but it doesn't
  #5
Senior Member
 
weihong yao
Join Date: Mar 2009
Posts: 117
Rep Power: 8
ivanyao is on a distinguished road
hi,
thank you!but it doesn't work.it show
Usage:setParabolicInlet <root>.....-z_noncenter -parallel -y_noncenter,
ivanyao is offline   Reply With Quote

Old   September 25, 2008, 07:57
Default Try setParabolicInlet . backw
  #6
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,914
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Try
setParabolicInlet . backwardStep inlet 0.01 -z_noncenter
The dot is important. And the stuff iwht a - in front is optional
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   September 26, 2008, 03:11
Default ok.i will try it!thank you1
  #7
Senior Member
 
weihong yao
Join Date: Mar 2009
Posts: 117
Rep Power: 8
ivanyao is on a distinguished road
ok.i will try it!thank you1
ivanyao is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with compile the setParabolicInlet ivanyao OpenFOAM Running, Solving & CFD 6 September 5, 2008 20:50
The setParabolicInlet problem ivanyao OpenFOAM Running, Solving & CFD 6 August 27, 2008 22:59
Problem in Modelling Heat Transfer Problem Deepak R FLUENT 1 December 6, 2007 10:37
Problem in Tutorial problem of fluent Phanindra FLUENT 5 April 17, 2007 09:57
problem in solving "wave generation" problem san FLUENT 2 April 3, 2006 23:37


All times are GMT -4. The time now is 13:05.