CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

Execution time problem after first write interval

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 25, 2008, 14:46
Default Hi, I am currently running Op
  #1
New Member
 
Sean McIntyre
Join Date: Mar 2009
Location: State College, PA
Posts: 11
Rep Power: 8
sean_mcintyre is on a distinguished road
Hi,
I am currently running OpenFOAM 1.4.1, and have been experiencing a problem with the solvers (currently rasInterFoam, though it has shown up with other solvers as well). When running parallel jobs, the execution time increases from about 15 seconds per time step to about 10000 seconds after the first write interval, and stays that way. Upon upgrading to 1.5, we still experienced the problem, which doesn't happen in single processor jobs. In 1.4.1-dev, it was less notable, only about doubling the execution time. Has anyone else been experiencing the same problems? If so, do you have any idea what's the cause? I have used both LAM and OpenMPI, and had the same problem.

Thanks,
Sean McIntyre
sean_mcintyre is offline   Reply With Quote

Old   July 28, 2008, 04:36
Default Hi Sean, We've had the same
  #2
Member
 
Roland
Join Date: Mar 2009
Location: Netherlands
Posts: 62
Rep Power: 8
sylvester is on a distinguished road
Hi Sean,

We've had the same problem. It was related to an NFS bug in the RedHat kernel. I don't know which version, but updating the kernel solved our problem.

Sylvester
sylvester is offline   Reply With Quote

Old   July 28, 2008, 05:12
Default I can confirm this. I think it
  #3
Senior Member
 
Eugene de Villiers
Join Date: Mar 2009
Posts: 725
Rep Power: 12
eugene is on a distinguished road
I can confirm this. I think it was RHEL 4 update 3. We never found out why it happened only with OpenFOAM though.
eugene is offline   Reply With Quote

Old   July 28, 2008, 08:46
Default Thank you so much! I'll have
  #4
New Member
 
Sean McIntyre
Join Date: Mar 2009
Location: State College, PA
Posts: 11
Rep Power: 8
sean_mcintyre is on a distinguished road
Thank you so much! I'll have to see if our HPC person can update the kernel for us. We wanted to just blame LAM, but it happened with the MPI too. Thanks again,

Sean McIntyre
sean_mcintyre is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there a way to write the time step size, time a may FLUENT 6 November 22, 2009 12:52
why did my time interval set for output nouse? ShFlow FLOW-3D 2 January 11, 2009 21:25
Reading case file at certain time interval Chin Fook FLUENT 1 September 11, 2008 06:54
Measuring an Execution Time - f90 su Main CFD Forum 11 July 4, 2008 07:21
Execution problem Jiri CD-adapco 3 October 16, 2003 09:46


All times are GMT -4. The time now is 11:39.