CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Running, Solving & CFD

buoyantFoam OF15 very strange behaviour in hotRoom

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 24, 2008, 03:11
Default Dear OpenFOAM community, I'
  #1
New Member
 
Andrea M.A. Barbera
Join Date: Mar 2009
Location: Turin, Italy
Posts: 7
Rep Power: 8
andrea_barbera is on a distinguished road
Dear OpenFOAM community,

I'm a new OpenFOAM user and I hope that I will not make too many mistakes writing my first posts.

I have tried the tutorial hotRoom in the new release 1.5, and the behaviour of this case is different if compared to the one that we had in release 1.4.1: even if in the room there is only the usual hot source, at the end of the 400 seconds of simulation the mean temperature in the room is diminuished by 40 degress, and would continue to diminuish without reaching a steady state. The velocity field, however, seems correct according to me.

Is this only a large numerical error? And if it is, why it did not happen in release 1.4.1? Can someone help me to skip this problem?

Thanks

Andrea
andrea_barbera is offline   Reply With Quote

Old   July 25, 2008, 09:59
Default Hi Andrea, Could be a bug i
  #2
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Hi Andrea,

Could be a bug in 1.5. Can you post a bug report and we'll have a look at it.
mattijs is offline   Reply With Quote

Old   July 28, 2008, 04:10
Default Hi Mattijs, I would post it
  #3
New Member
 
Andrea M.A. Barbera
Join Date: Mar 2009
Location: Turin, Italy
Posts: 7
Rep Power: 8
andrea_barbera is on a distinguished road
Hi Mattijs,

I would post it really with pleasure but, sincerely, I do not know what does it mean in detail. Have I only to report the involved files and the assignments used to run OpenFoam or it means something else, perhaps explained in some page that I did not found?

I'm sorry not to know this procedure, but I'm still a new user in this forum. I hope that I will learn as soon as possible!

thank you!

Andrea
andrea_barbera is offline   Reply With Quote

Old   July 28, 2008, 05:23
Default Hi Andrea, http://www.openc
  #4
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Hi Andrea,

http://www.opencfd.co.uk/openfoam/bugs.html.

(go to the OpenFOAM-bugs section and use the 'Bug report template' as a template to post a bug report. Most helpful to us)
mattijs is offline   Reply With Quote

Old   July 30, 2009, 09:06
Default buoyantFoam bug?
  #5
New Member
 
Pal Schmitt
Join Date: Mar 2009
Posts: 28
Rep Power: 8
waterboy is on a distinguished road
Have You found anything? A bug?
I have been trying to use buoyantFoam with FOAM version 1.5 or 1.5 dev, but it does't seem to make sense.
Setting all the walls to fixed temperature 300K and writing out thermo->T() I get
Quote:
Min(T) = 267.941 Max(T) = 600
at the last timestep 400s.
First timestep is OK with T between 300 and 600.
If using the original case the drop in minimum temperature is not as big but still there.
Since the air starts moving I believe the error is in thermo, it should get hotter in the room, or not?
Is there some BC issue I am missing?Should real air be defined differently?
The values in constant/thermophysical... seem all right to me
Quote:
mixture air 1 28.9 1000 0 1.8e-05 0.7;
pRef 1e5;
I hope someone comes up with the solution, the coarse mesh doesn't seem to be the main issue either...

Last edited by waterboy; July 30, 2009 at 11:53.
waterboy is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange behaviour when using LienCubicKE and NonlinearKEShih hani OpenFOAM Running, Solving & CFD 20 March 6, 2013 11:06
BuoyantFoam and hotRoom in 15 egp OpenFOAM Bugs 9 February 24, 2009 07:52
Strange multicomponent source behaviour Zitron CFX 4 July 12, 2007 15:32
Strange Behaviour in CFX-Mesh Kasper CFX 0 May 14, 2007 08:24
Strange behaviour in Coffus Luis Filipe Fabiani Phoenics 0 June 1, 2006 11:23


All times are GMT -4. The time now is 21:14.