CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Running, Solving & CFD (http://www.cfd-online.com/Forums/openfoam-solving/)
-   -   SimpleFoam Error with librdmacm amp libibverbs (http://www.cfd-online.com/Forums/openfoam-solving/58723-simplefoam-error-librdmacm-amp-libibverbs.html)

dnomdec July 17, 2008 17:21

Hi all, I am trying to run
 
Hi all,

I am trying to run simpleFoam (1.4.1) in parallel. When I ran in double precision, things seem to work OK. However, in single precision, I got the following error (on each processor I am running):

librdmacm: couldn't read ABI version.
librdmacm: assuming: 4
libibverbs: Fatal: couldn't read uverbs ABI version.
CMA: unable to open /dev/infiniband/rdma_cm
--------------------------------------------------------------------------
[0,1,0]: OpenIB on host hpcs01 was unable to find any HCAs.
Another transport will be used instead, although this may result in lower performance.

Does simpleFoam require different/extra libraries in single precision vs. double precision? I could find librdmacm.so, libibverbs.so and libmthca.so in /usr/lib. The funny thing is, I don't even have infiniband on my cluster.

I'm quite new to OpenFOAM, so any help is appreciated.

Thx!!
Ned

sidharth May 21, 2010 08:02

Check the OFED version
 
Hi,

I had the same error.
The problem was due to the mismatch in OFED version and the kernel version.
Install the latest version of OFED and check if it supports the kernel version that you are using.
It worked for me.

All The Best!!!
Sidharth Kashyap


All times are GMT -4. The time now is 18:25.